Users auto search not working


After upgrade from Owncloud 8.2.9 to Nextcloud 9.0.54 to Nextcloud 11.0 I’have problem with sharing via web interface because when I tape username in the field it said user or group not found. but sharing work fine via desktop client.

Could you help me.

Do you use external authentication modules (imap/ldap/…)? Logfiles, browser console? Tried different browser/disabled plugins?

I quickly tried on my test setup but couldn’t reproduce this.

I don’t any external autentication
however when i tape anything it says user or group not found but when I tape good start usernames it don’t propose or displays users or groups starting with.

the activated apps are:

You must type something to start the search. The behavior of your search box is different from mine, if I search for “gr” (I don’t have a user or group which corresponds to that string), the box gets a red color and a message “no users or groups found for gr” is shown.

I suspect there are some javascript or styling stuff from some apps that don’t work together. Can you temporarily disable the non-default apps, from your list I would say: Rainloop and Spreed.Me. Also disable if you use a personal theme.


Thanks for your reply I’ve deactivated Spreedme, Rainloop and direct menu but always the same problem for the theme I don’t have a personnal theme only I changed the logo and slogan.
I’ve also deactivated log reader and theming but always the same problem.


When I type wrong user ex:sefkcklc it says user or group not found when I type a complete username as: gidriss it don’t add it in share simply now I can’t share in the web interface

What do you mean by that? How many users do you have (could be that they implemented a threshold for a certain amount)?

for example I have user (gidriss) when I type “gi” nothing proposed also when I type “gidriss” completly no users proposed to share with, now shares can be done only by desktop and mobile clients.

Did you check if browser plugins are blocking this feature? Can you try a different one (I tested on a current firefox).

We haven’t this problem only after upgrading from Owncloud to Nextcloud, and all users have same problem, so it is not browser or plugin problem.


I’m running out of ideas. If there is nothing special about your setup (reverse proxy, mod_security, apache other than mod_php, …), a bug report on github could help. You actually gather more detailed information so that the developers can reproduce your problem.


I’have another installation of nextcloud 11.0 but not upgraded from owncloud on another subdomain, and it works fine, without any bug.
but when I set the DB and datafolder in config.php to the DB and data folder of the first subdomain, I had the same problem, no possibily to share via web.

Yes, then please open a bug report.

It sounds like there is still a bug report opened, other people are facing this: