Used NextcloudPI install script on Debian and I am stuck

ncp

#1

I was able to run the install.sh script from here https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | which appears to have completed correctly. However, although I can get to the nextcloud server using the ip address of the machine, I can not get to either the NCP web page or to the wizard. Also the server (if I leave off the :4443) puts me at the initial configuration screen and indicates that I failed to connect to the sql database with an access denied message.


#2

Sounds like a permissions issue. Are you running this on a Raspberry Pi or different architecture? What version of Debian are you running? Could you please copy and paste the error you are seeing.

Fyi, you can also access nextcloudpi-config from the terminal.


#3

I am running it on an old laptop. It installed fine on a raspberry PI 2, but I had an old Celeron laptop that I wanted to re-purpose. I am running debian-9.2.0-amd64 w/ gnome.

Where is the nextcloudpi-config located.


#4

Just type sudo nextcloudpi-config into the terminal on the target machine.

I would try updating and upgrading your Debian install to the latest version of all packages via apt-get or aptitude.

sudo apt-get update && apt-get dist-upgrade

If no dist-upgrade available…

sudo apt-get update && apt-get upgrade

#5

Thanks I will try in the morning.


#6

A sudo nextcloudpi - config

returned

sudo nextcloudpi-config

sudo: nextcloudpi-config: command not found


#7

The first apt-et command in your post did work in updating the Debian


#8

Trying to get to the wizard got this

Not Found

The requested URL / was not found on this server.
Apache/2.4.25 (Debian) Server at 192.168.1.220 Port 4443


#9

If the nextcloudpi-config wizard was not found I doubt it installed properly to begin with. I’d try re-running the installation script using root privileges.

# curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | bash

#10

still no luck- curl did not work under root, cd command to where I had saved a copy of the install.sh script and it ran without errors but still same result with the ncp web interface as well as not finding nextcloudpi-config


#11

I got curl to work by running as root apt-get install curl
curl is now working, but still no joy on finding nextcloudpi-config either running as root or using sudo


#12

If you didn’t have Curl installed you would not have been able to run the script at all. Please re-execute the script as I mentioned above.


#13

I did re-execute it it same result. I can pipe the output of the command to a text file if that helps in debugging?


#14

i’m sure @nachoparker has some answers for you. afaik there’s no working version of ncp for non-arm machines. but as i said nachoparker will haver more infos for you about this


#15

I may have finally got it! The order of things makes a difference. I reinstalled Debian, used sudo su -, ran all the debian updates, added the curl command, then ran the install script and it seems to have progressed. I can now get to the ncp web page. I will try to get all the settings that seem to work of my raspberry pi version and “port” them over to the laptop with debian