USB drive forces reboot - NCP on RPi Model B

Hey guys,

after some tinkering with NCP, I tried to run the wizard to store data on the USB drive. At this point, i really got frustrated, because everytime i plug in the drive it keeps rebooting the pi.
The chronologically procedure:
Installing NCP on SD-card with dd and so on. Everything works fine. (Tried two SD-cards)
Seeing the boot procedure on my monitor. Activating over LAN, starting the wizard.
Now, if i plug in the USB stick, the monitor doesn’t show any console and after 3 seconds the Pi reboots.

Also this happens when I don’t run the wizard, plugging the USB drive in at any given time.
I tested with another SD-card (8GB/32GB), power-brick (both 1,5A at 5V), tried to use both USB ports on my Pi, installed the image several times new, with and without a keyboard. Both USB drives are from Intenso (4GB USB 2.0 / 64 GB USB 3.0) Both formated to ext4/FAT32/NTFS.

EDIT: Forgot to mention, that it worked once on the 4GB stick, after pulling it out and plugging in 64GB stick, it rebooted again.

Does anyone know how to fix this issue? I don’t want to keep all data on the USB-drive, but want to safe backups to it.

(Thanks nachoparker for this awesome RPi-config)

Thanks in advance :slight_smile:

hi,

sounds like you have a hardware issue. Use a good power supply, get a nice SD card and use hard drives with their own power supply if possible

1 Like

just to be on the safe side…
have you tried flashing a different OS on the SD-card (like raspian lite)… and then trying to plugin your usb-sticks?
have you tried usb-sticks of a different manufacturer?

If it’s a Pi3 then a 1.5A PSU won’t be enough to support it and an external drive (presuming it’s USB powered). To be honest I’m surprised it even powers your Pi anyway, as it’s very borderline at that current.

Go for at least a 2.5A one (the official foundation PSU is strongly recommended), and maybe consider a powered hub if your drive is USB powered and particularly power hungry.

Editted to add - this one:

https://www.raspberrypi.org/products/raspberry-pi-universal-power-supply/

I’m running NextCloud (via Docker) on a Pi3 with a WD MyPassport USB drive all powered by one of those, and it’s rock solid.

1 Like

Thanks guys for your advice,

it’s just a Model B not even B plus.
Never had a problem with 1.5 Amps. Like i said, there is no problem with powering a gaming keyboard and mice. So i really don’t think, the power supply is the problem.

But will try to test with USB-sticks from another manufacturer.
Maybe the time has come to get a new RPi Or a Rock64 after 5 years or so.

Will post a update if i got it running or not.
Thanks again,
Max

well… don’t be too sure about your anticipation. @nachoparker and @DarrenHill are right, both - i’ve seen several problems arising from a wrong powersupply, especially when using a rp3 with nc. so you’d better don’t put their suggests away, easily.

The 3B is actually the most power hungry of all the Pi versions - the 3B+ is reported to be a bit more power efficient (and as a result also runs a little cooler) through some hardware improvements.

See the link below for details of the whole family (except the 3B+):

Also note the recommendation there for using the 2.5A PSU, ideally the one linked above. And for £8, it’s not exactly a bank-breaker :wink:

Hard drives are very power hungry themselves, much more so than solid state devices (SSD’s and USB sticks). In many cases the Pi (and version) can struggle to supply enough current via USB for one, at which point the options are either a self-powered drive or a powered USB hub to take the load off the Pi.

So, here i am again.
tl;dr
Raspian,4A 5V Powersupply, = same outcome
lsblk + File Manager works fine if USB-Stick is inserted before bootup.

EDIT: This is the version i own. No three, no plus, just B :b Model B .
Raspian Stretch is the same outcome. Everything works fine (keyboard/mouse) until i switch it to a USB stick. As soon the gold contacts hit the Port, screen goes black.
Also found another Power Supply. It says 5V 4Amps. Same problem.

Will also add to this, that both USB sticks work flawlessly (is that even a word?!) on Fedora and Debian. Even if the Pi rebooted (or boots for the first time), with the USB-stick still in the port, everything seems ok. I can open the File Manager and see the data on the USB Stick.

As i am writing this,after opening terminal ‘lsblk’, my Pi fell, it disconnected the drive, then reconnected it. After that i could remove the 4GB stick and plug it back in as often as i want, but the 64GB gave a blackscreen and reboot. So… Power supply can’t be the problem, or am i really that off the track?

Max :slight_smile:

Ok the original model B is much less power hungry - see the link I posted above. But still the initial plug-in of any USB device is where the power spikes, which leads to undercurrent to the Pi itself through the draw through the USB port and when things go bad. It’s especially bad for HDD’s as spinning up the platters takes a lot of juice.

The sure-fire way to tell is if you have a powered hub available that you can use between the two, then the drive will be pre-spun up and won’t take anywhere near as much power (if any at all).

I’ve not personally had much experience with this kind of thing on NCP, but I’ve had more than enough of it using Kodi (I’m a Team Kodi member) with users doing exactly what you’re doing there and causing all sorts of mayhem power-wise.

One other thing you could try is a USB extension cable if you have one or can get one cheaply to ensure that the physical act of plugging in the drive isn’t causing the issue (via earthing issues or other contact problems). But what you describe is absolutely classic for power - smaller USB sticks tend to draw less power than larger ones, and those in turn draw much less power than hard drives.

Also is your 4A supply one with a built-in cable, or one where you plug one in? The other issue we tend to see with Kodi is people using decent current PSU’s but cheap thin wire cables that drop large amounts of the current before it gets anywhere near the Pi through their resistance. If your PSU needs an additional cable, make sure it’s a short chunky one with as thick a wire gauge as you can.

1 Like

Okay, sooooo… now i am really confused. You were right. I searched in my cable box for the 2m USB extension cable and both usb sticks work just fine. I don’t get it. It seems that grounding won’t work? But then, why am i capable of using the same Port with Mice/Keyboard/webcam etc?

Thanks Darren, maybe if you could tell me the details for understanding what was really the problem would be really appreciated.

My experience of this before was simply the act of inserting the USB plug caused movement and perhaps bending on the board or connectors and it momentarily interrupted the power connection causing the reboot. Also I’ve known a dodgy grounding issue where the physical act of holding the Pi was enough to change the grounding and caused an issue (in the end that one was down to a dodgy PSU).

I can’t give technical answers as to why, just from experience of similar issues happening from either power or grounding. Anyway glad it’s given you a way forward anyway.

1 Like