URL in notification email link includes index.php which does not load the poll page

Notification emails for the Polls app – that are sent for example when someone votes – have a URL like https://example.com/index.php/apps/polls/vote/2. This URL loads the nav bar and there are no errors in the browser console, but the page content is blank. When I remove the index.php/ from the URL so that it is https://example.com/apps/polls/vote/2, it loads properly.

I am using the official Nextcloud Helm chart with Nextcloud v22.0.0.

Check the CLI configuration. See also

Additional information:

I think this helps better.

Yes, this is exactly what is happening. It looks from the GitHub issue that there is no solution yet. But that doesn’t make sense, because this bug would have been noticed long ago before the app was released. That makes me suspicious that there is something unusual about my configuration.

Here is my config.php which I should have included in my original post:

<?php
$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 => 
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'nextcloud-redis-master',
    'password' => '',
    'port' => 6379,
  ),
  'overwriteprotocol' => 'https',
  'trusted_proxies' => 
  array (
    0 => 'traefik',
  ),
  'passwordsalt' => '************',
  'secret' => '***************',
  'trusted_domains' => 
  array (
    0 => 'cloud.example.com',
  ),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'version' => '22.0.0.11',
  'overwrite.cli.url' => 'https://cloud.example.com',
  'dbname' => 'nextcloud',
  'dbhost' => 'nextcloud-db-primary',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '************',
  'installed' => true,
  'instanceid' => '***********',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'smtp.example.com',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'devnull',
  'mail_domain' => 'example.com',
  'app_install_overwrite' => 
  array (
    0 => 'groupfolders',
  ),
  'maintenance' => false,
);

Did you try 'htaccess.IgnoreFrontController' => true ??

1 Like

I have not tried that. Thanks for the suggestion. Are there side effects of that setting I should know about? It’s not clear from the manual.

Thanks, that solved the problem. I have not noticed any new problems caused by that config change.