Uprading PHP in TrueNAS iocage

I know, I know…someone is about to say something about how many posts there are on topics related to this…and I’ve spent many hours trying to find what I need to no avail. And I also realize this is Christmas Day and I’m also scratching my head wondering why I’m spending the evening spinning my wheels on this. Thankfully, my NC service is for personal use and I’m not supporting anyone but myself. :wink:
So here’s my scenario - I’ve installed NC on an iocage jail in TrueNAS and am using nginx. In the admin section of the UI it’s been nagging me to upgrade from php 8.0 to at least 8.1. I’m attempting 8.2 so I don’t have to do this again in the near future.
I’m fairly green when it comes to hosting, so I’ve had to ask the interwebs quite a bit just to get this far. But I find myself at an impasse. The following is what I have done thus far:

  1. Made snapshots of my NC jail (I didn’t just fall off the turnip truck)
  2. shelled into the jail and performed: pkg info | grep php to get the list of php extensions being used
  3. performed pkg install php82 php82-bcmath php82-bz2 php82-ctype... through the entire list of nearly 30 packages. This simultaneously installed the new and removed the old for each one. There was one package that did not have a package in 8.2. That was pecl-imagick. so I had to skip that one.
  4. service nginx restart

All I get is 404 error no matter what. I’ve also completely stopped/restarted the entire jail.
From reading other guides, it seems there could be some references to php 8.0 that need to be updated in 8.2 in conf files possibly. But I can’t seem to find any references like that - most of the posts I’ve read have been for people using apache. So I’m hoping someone knows something very simple that I’m overlooking.

BTW, I also tried upgrading from outside the iocage using: iocage exec nextcloud pkg upgrade iocage exec nextcloud pkg install php82...
Got the same result this way…well and it actually upgraded a few other things along the way. But the end result was still 404.

Merry Christmas all! Thanks in advance for any help.
:christmas_tree:

I’ve spent countless hours researching this and trying different things and have come up empty. I’m starting to think the best thing is for me to just create a new jail and NC instance from scratch with the upgrade to php82 and then migrate config/data over into it. Maybe that will work??? I have no idea if the NC app package included with TrueNAS is updated or not, but will give it a shot. As far as migration is concerned, hopefully that won’t be too bad, right? lol. I mean how hard can it be for a newb to migrate data from one iocage to another? :slight_smile:
I’ll post here with updates in case anyone ever comes across this with the same issues.