Uploads over 100MB doesnt work after configuration


#1

Hello community,

i am writing here as i could not find the reason and solution why i cannot fix this behaviour. Generally the installation is working great - also i do not have a single error in my log. But i still cannot upload files bigger than 100mb.
In the nextcloud and php settings i have set the limit to 10Gb but still no chance to upload files bigger than 100mb.
I have apache2 installed with nginx as reverse proxy. Might there be a problem with nginx or a configuration i need to consider there?
Unfortunately i cannot post any error because there is none except one in the apache log.

The only thing i recognized, that there is a small white artifact apprearing when the file upload has been completed - but still the file won’t be accepted or visible…

Any ideas how to find the error and fix it?

Thanks so much!


#2

Create a new file somewhere in your webroot and name it “test.php”.

Enter the following text:

<?php phpinfo(); ?>

Now when you open this URL in your web browser, inspect the upload_max_filesize or post_max_size values.

It may be that PHP is limiting the upload_max_filesize. If I am not mistaken, on the nextCloud administration web page where you specify the max upload file size for your server it will warn you if this is the case.

Note that WebDAV has a 4GB file size limit as part of the WebDAV protocol.


#3

Hello telleropnul,

thanks for you guidance - did that now and checked the values. both values are set to 10000M.

Within the nextcloud installation the same value is showing up - but grey’d out. I cannot see any error message or warning onto this site too.

Any further ideas?


#4

Just in case you have mod_security enabled, check those settings as well.


#5

I dont have mod_security enable. just nginx as a reverse proxy. But there is no config to limit that…

Thanks - any other ideas?!


#6

Are you using cloudflare? They limit upload to 100mb


#7

No i dont have cloudflare.
I am already clueless…invested hours of time but could not clear why this limit still occurs. all the different settings (PHP, Aparche, .user_ini) showing the 10Gb values but still not working…


#8

have you tried to upload it with a different browser?


#9

Thank you - nice catch. With firefox i can see the error message now.

Request Entity Too Large

I am now checking which settings i need to adjust for SSL that it finally works…

Thanks,


#10

Just another update.
I have now been running the update to the new published version, but still did not help.
I cant get it to work. Checked .htaccess .user.ini checked nginx and php.ini…

Any other ideas why i am still having that limit? It’s really weird…


#11

Are you on a shared hosting account? If so contact your hosting provider most likely they have to get this resolved for you from the system php.ini file not in your local one if this is the case. My 2 cents.

Also check the following link for the Request Entity Too Large 413 error https://craftcms.stackexchange.com/questions/2328/413-request-entity-too-large-error-with-uploading-a-file


#12

Thank you will check this.
It is a Virtual server - but has no limitations in regards to user_beancounts so far (except memory and hdd of course).

I will check the link and see if i can solve it…

Generally all those settings have been checked (nginx, apache, php.ini) and edited couple of times - i gonna freak out soon :slight_smile:

UPDATE:
Unfortunately non of them helped…in every config limit is not showring 100mb but still having that issue.

Might there be another option somewhere in the database?

Thanks