Upload problem files >1GB with yellow exclamation mark

I have the problem that files larger than 1GB are not uploaded correctly to my Nextcloud Server, hosted on IONOS.
This problem has existed for several years with various versions of Nextcloud, so far I have been able to live with it.

The error looks like this:

  • Using NC version 3.6.4 on Windows 10.
  • The files seem to be copied to my NC server V25.0.2
  • NC shows at some point that the upload is finished. The status is green in the settings window
  • However, in Explorer there is a yellow exclamation mark next to the file’s icon.
    => The file cannot be found via the web browser in Nextcloud.

Under “Logging” on the server there is no error message about the process.

Where can I find more information about the problem on my client or on the server?

What additional information should I provide that you are able supporting me?

Many thanks in advance

Nextcloud version : 25.0.2
Operating system and version : Debian GNU/Linux 10 (buster)
Apache or nginx version : apache unknown version (IONOS server)
PHP version : 8.0.26

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): N

The output of your Nextcloud log in Admin > Logging:

no logs regarding this problem found

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '*******',
  'passwordsalt' => '*******',
  'secret' => '*******',
  'trusted_domains' => 
  array (
    0 => 'sudomain.mydomain.de',
  'datadirectory' => '/homepages/xx/dxxxxx/htdocs/NextCloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://sudomain.mydomain.de',
  'dbname' => 'dbsxxxxx',
  'dbhost' => 'dbxxxxx.hosting-data.io',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'dbuxxxxxx',
  'dbpassword' => '*********',
  'installed' => true,
  'default_phone_region' => 'DE',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'myname',
  'mail_domain' => 'mymaildomain.de',
  'mail_smtpsecure' => 'ssl',
  'mail_smtphost' => 'smtp.ionos.de',
  'mail_smtpport' => '465',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'me@mymaildomain.de',
  'mail_smtppassword' => '************************',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:

no access to this information


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Sorry, no actual errors to find


Have you tried to enable audit logs ?
There is no particular error on a more generic log file on the server ?

I have now activated the "Auditing / Logging " app. I will do a new test and see if I get more information.
What logfiles could contain information? I only have access to the Nextcloud instance. Not to the server itself, since I am with NC at IONOS.
I only have the log file /nextcloud/data/nextcloud.log so far. I could not find any clues to the problem. Only old stuff from the last years :grinning:.

here the result from my last upload test.
I have now uploaded a 4.4GB file. The Nextcloud client shows that everything has been uploaded.

In the windows file manager, there is a red dot with a white cross next to the file icon.

The file is not visible on the server.
I still cannot see any log entries that indicate a problem :thinking:.
There must be an error message somewhere, but where to find?

The autit.log was generated but is empty.
The nextcloud.log contains only a login failure. I typed in a wrong password :wink:

{"reqId":"Y6tDzC7CIsrF@RRRZZR9WwAAAAk","level":2,"time":"2022-12-27T19:13:16+00:00","remoteAddr":"xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx","user":"blabla","app":"no app in context","method":"GET","url":"/index.php/settings/admin/groupware","message":"Invalid google_oauth_client_id data provided to provideInitialState by mail","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:108.0) Gecko/20100101 Firefox/108.0","version":"","data":[]}
{"reqId":"Y63T0CK8XRRRRYfpdMhX2wAAAAQ","level":2,"time":"2022-12-29T17:52:17+00:00","remoteAddr":"xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx","user":"--","app":"no app in context","method":"POST","url":"/index.php/login","message":"Login failed: blabla (Remote IP: yyyy:yyyy:yyyy:yyyy:yyyy:yyyy:yyyy:yyyy)","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:108.0) Gecko/20100101 Firefox/108.0","version":"","data":[]}

Are there any further iedeas to debug this problem?

From your answers I think it’s the way, your server is configured that create that silent file drop.

Do you have some documentation about the NC template IONOS gave you ?

It might be a php limit or a hard-drive limit on the IONOS server.

Unfortunately, I don’t have any further information about the server. I have only booked a web hosting package at IONOS. Nextcloud was installed by myself a few years ago. Since then, I have always installed the updates via the web frontend.
So no template from IONOS was used.

Maybe I should contact the IONOS support team with this problem. As soon as I have new information and can’t get any further, I’ll get back to you here.

In any case, many thanks for the help and I wish you a happy new year.


I forgot to give you this : https://docs.nextcloud.com/server/latest/admin_manual/configuration_files/big_file_upload_configuration.html.

I case you have not read it already, it list parameters that can limit the maximum file size for uploads.
But I have not jumped on this conclusion because, from my experience, if it was the root cause of your issue an error message should be visible.