Upload filesize limitation

Hello Dear Community,

i have problem with my Nextcloud configuration:
Im runnning Nextcloud 17.0.0 on Docker with Docker-Compose and using nginx as reverse-proxy.
All works fine except that there is a fileupload limitation at approximatly 1 MB. I already configured the “client_max_body_size” in the http{}-block in my nginx.conf but it didnt help.
Does anyone can help me?


By default you can upload only 2MB. You have to change the php config. I’m not sure which options you have in Docker but the easiest way is probably to mount an ini-file into /usr/local/etc/php/conf.d/
This file should include:


Or wathever size you prefer.