Upload Fails by stopping as 'A Few Seconds'

I have a brand new install via softalicious into a subdomain and I am the only admin at present.
The system seems to be working fine, I can see the files and pictures, I can delete files and pictures and i can set the upload in motion, but it doesn’t complete.
I tried to upload a small (512kb) .docx file and it get to ‘a few seconds’ on the progress bar and stays there for ever. Same with a picture of 1.4Mb .jpg.
There are no error messages, no popups, nothing. The screen is not frozen as I can navigate from the page without any problems.
The only thing I have done from the basic install is activate encryption and encrypted the home storage.
Any ideas?

I have the same situation - a brand new installation. Everything appears to work. I can create directories, create text files, pass the security scan etc, but when I upload a file I get the ‘a few seconds’ message and no more.
I running nextcloud on a cpanel account, installed from the zip download. I’m using Safari as my browser. Everything is default settings.
Ideas would be useful!

Further to my last, and in line with RobertH, i have uninstalled and reinstalled via Softaculous on Cpanel with the same results, no completion of the upload.
I have a shared server, using Cpanel, using Google Chrome and IE and Edge with same results. The Data folder is correctly placed and I tried, briefly, with chmod of 777 to see if that helped. Nothing worked.

I read https://help.nextcloud.com/t/all-web-mobile-uploads-fail/33018/12. As I’m server admin, I disabled modsecurity for the account, and all work well - it resolves my issue.

I hope this works for @sjgarth as well!

This could be mod_security as @robertH OR a bad php-fpm config.


/etc/php/7.2/fpm/pool.d/nextcloud.conf and add/modify request_terminate_timeout to 300

listen = /var/run/nextcloud.sock
listen.owner = nextcloud
listen.group = www-data
user = nextcloud
group = www-data
pm = ondemand
pm.max_children = 56
pm.process_idle_timeout = 60s
pm.max_requests = 500
request_terminate_timeout = 300
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tm

etc/nginx/sites-available/nextcloud and add/modify fastcgi_read_timeout to 300

server {
 location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+).php(?:$|/) {
        fastcgi_split_path_info   ^(.+.php)(/.*)$;
        include                   fastcgi_params;
        fastcgi_param             SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param             PATH_INFO $fastcgi_path_info;
        fastcgi_param             HTTPS on;
        #Avoid sending the security headers twice
        fastcgi_param             modHeadersAvailable true;
        fastcgi_param             front_controller_active true;
        fastcgi_pass              php-handler;
        fastcgi_intercept_errors  on;
        fastcgi_request_buffering off;
        fastcgi_read_timeout      300;

PS: this is from a working nginx/nextcloud server, you may have to get the good location

having the same problem. mod sec is not the problem. any further ideas?