Upload failed via web-interface - upload via ftp?

Good morning, dear readers!

We have a current NC 10 running on a shared hosting system. Running it locally is not an option as the bandwith avaliable at our address is too low for any meaningful usage of NC - for people not in the office. As a result, I only have access to a very limited number of settings for the httpd and the typical restrictions for shared hosting (especially script run times) apply. I do have shell access however, even though this is somewhat more limited than I would like.

Yesterday I tried to upload a rather large pdf (~90MB). It a complete product documentation and contains //lots// of images. The upload failed each time, meaning all looked fine until the counter got below 10 seconds, where it stopped. As you might have guessed, I tried uploading the file several times. The counter stopped on different numbers (6 seconds, 2 seconds) but always below 10.

First of all: I am guessing that this is due to limitations of php script run time. Am I looking in the right direction here? Or is there another issue that could be causing this?

Because I needed the file up on the server, I uploaded it via ftp directly into the data structure. As expected, the upload succeeded but the file doesn’t show up in NC. Owner and access rights are the same as for the other files, I made sure of that. Is there some way to make NC scan for files and find this file? Note: The file in question is in a folder that is shared as part of a larger hierachy. I would like this information to stay intact of possible.

For the future: If it’s not possible to upload larger files via the web-interface for some reason, is there a way around this?

Thanks for reading and your help!

Kind regards,

1 Like

same issue here. it was taking forever to upload my initial massive directory, and then when completed (nice and fast with FTP) my user could not see the files! I’m stuck. They are all sititng there but it seems like NC doesn’t ‘see’ the files I uploaded directly to that users file. Any help?