Upload button in web interface is not working

Nextcloud version: 12.0.3
Operating system and version: Debian 9.2 „Stretch“
Apache or nginx version: nginx/1.10.3
PHP version: PHP 7.0.19-1

replicate the issue:

  • install current debian
  • install php
  • install postgresql
  • install nginx
  • install Nextcloud 12.0.3
  • log in to Nextcloud
  • click the upload button on the web interface in the files section

The issue:
When clicking the upload button (+) in the files tab of the web interface nothing happens.
When clicking the upload button (+) in the gallery everything works fine. An upload menu pops up and files can be uploaded. This upload dialog seems to be missing in the files section.

Some further information about my setup:
Debian with nginx and postgresql.
The nginx config parameters are set as described in the manual (https://docs.nextcloud.com/server/12/admin_manual/installation/nginx.html#nextcloud-in-the-webroot-of-nginx) except that I use the socket connection for the php-handler (server unix:/run/php/php7.0-fpm.sock;) instead of ip.

I tried the following browsers: Firefox(Linux and MacOS), Chromium(Linux), Chrome(Linux and MacOS). No error is shown in the browser console.

The output of your Nextcloud log in Admin > Logging:

My config.php:
‘datadirectory’ => ‘/var/www/nextcloud/data’,
‘dbtype’ => ‘pgsql’,
‘version’ => ‘’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘/var/run/postgresql’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘www-data’,
‘dbpassword’ => ‘’,
‘installed’ => true,
‘updater.release.channel’ => ‘stable’,

The owner of the nextcloud directory and files is www-data.

The output of nginx error.log:
access forbidden by rule, client:, server: localhost, request: "GET /data/.ocdata?t=1508944576957

Thank you for your help. Please let me know if you need further information.

Issue has been solved.

The part
location ~ .(?:png|html|ttf|ico|jpg|jpeg)$ {
try_files $uri /index.php$uri$is_args$args;
# Optional: Don’t log access to other assets
access_log off;
was missing in the nginx config file.