Upload bigger files with Windows Client

I upload just a few larger files with the Windows client on my NextCloud (11). They are some 100 MB up to 1.8 GB. Due to my weak-breasted Internet connection it takes it’s time. The maximum file limit is adjusted. But somehow I get the impression that they are not uploaded completly. The Windows computer with the client is usually only a few hours running. So not enough to upload a whole of these bigger files. How is the behavior of the client? Does it starts at the next startup of the computer again with the upload (I have this impression) or is the already uploaded part of the file still present on the server, and the client will continue with the upload?
Edit: This previous text is the translation on a topic I created five days ago in the German section. Unfortunately without an answer yet. However, I uses the time to observe the behavior of the client. It starts with 1 day left, 1.3 GB of… The client loads three files up in a couple of days until 21 hours left, 2.4 GB of … and then it restarts at 1 day left, 1.3 GB of… It seems that the server does not want to keep the uploaded file. I took one of these files and loaded it up via webinterface during 5 hours. It loaded and loaded and when there was 5 seconds left, the upload failed. No error message :frowning:

I guess it will be your php.ini

two PHP settings: ‘post_max_size’ and ‘upload_max_filesize’

Then there is script execution time.
max_input_time
max_execution_time

But problem here is, its global and scripts could time out with errors but you will of set such a huge value that they will run for ages.

Also there is the nextcloud admin setting for file size.

Someone else might want tack on some more knowledge here as not sure how you could just make that one script have a long time out.

Oh, I hink I lost. As my NextCloud is hosted on a hosted Server of my provider, I have no acces to the php.ini. The given parameters I found are:

max_execution_time 60
memory_limit 524M
post_max_size 64M
safe_mode Deaktiviert
upload_max_filesize 64M

and I cannot change them :frowning:

Usually somewhere in the control panel you can.

Might not be php.ini directly, just some settings somewhere.

I just a look again in the so caaled Control Center: I only found that Information, what the usual PHP.INI contains. No way to change something. I also had a look in the webspace: No PHP.INI found.

Either get your self on old computer and a copy of linux and self host or get your a VPS for $20 a year.

If you can not access and change fundamental parameters like that then your web hosting of choice is a total chocolate kettle.

1 Like

Actually, I do not feel nerd enough to run my own server. I had this idea a couple of months ago. Since then there is a RaspberryPi lying on my desk.

I should look for a new provider - but I’m lazy.

By the way: can it be, that the client hat always problems with *.mp4-files? My problems only occure with these video-files.

Prob because Vid are usually large, they where probably the biggest.

Yeah a USB external and the PI will do the trick. :slight_smile:

I haven’t got my Pi3 anymore as it got donated but did a debian install in the forum as had some probs my self at first.

Pi or VPS its just a copy and paste.

Not sure why the Nextcloud guys are not doing Nextcloud hosting for non-commercial in a similar way Wordpress does where you can download source, or just get a subscription.

I think because is just quite expensive.

Next idea: if it’s just a problem of some timeouts on the server, than I should can load these files up with a faster internet connection?

Prob not there are defined limits in the http file upload & header.
The time might play a part also and time out, but you are prob hitting the filemax first.
But the scripts and execution time also have defined limits.

A faster interconnection would help as uploads are usually 1:10 of download speed.

But setting your PHP settings is a first.