Upgrading from to 24.0.3

My instance hasn’t been upgraded in a while. Today felt like the right day to actually bump my Nextcloud-version to the most recent one, so I SSH’d into my server and used ncp-config to perform a nextcloud-upgrade. However, my terminal reported the following progress:

# (...)
Maintenance mode enabled
backup database...
backup files...
backup /var/www//nextcloud-bkp_20220904_1662303713.tar.gz generated
Maintenance mode disabled
Install Nextcloud 24.0.3...
Fix permissions...
Nextcloud is not installed - only a limited number of commands are available

  Command "upgrade" is not defined.  

Clean up...
# etc

Is there anyone else with this problem, and is it fixable? If yes, how should I fix it?

My system runs on Armbian @ the Odroid n2+

It think it would be helpful to get some more information.

Do you use a 32- or 64 bit OS?
Which version of armbian do you use?
From which version of ncp have you upgraded?
From which NC version did you upgrade?
Do other ncp commands work?

Do you find anything in the logfiles?

Thanks for your lightning-fast response.
I’m on a 64 bit OS, Armbian 22.05.3
I’m on the most recent NCP-version (1.49)
Nextcloud-bump (see title): from to 24.0.3
ncp-commands work perfectly fine, I just upgraded my ncp to the most recent version before performing the Nextcloud-upgrade.

The ncp-logs do not mention any more than I mentioned in my initial comment.

Maybe run ncp-report share output via pastebin or similar.
I just upgraded from NC23.0.8 toNC24.0.3 using ncp-config, worked like charm.
Then manually set to 24.0.4 worked fine too.

Hi @OliverV , I will once NCP is available again. However, it is still restoring the database-backup at the moment :thinking:
How long is that supposed to take?
CPU-levels are close to 0%, thus the machine isn’t really showing any effort… But I’ll give it some more time. In the background I see that ncp-restore is “active”

edit: ah it is heading toward the finish

Pastebin.com - Locked Paste => use password 93bGN2j7NJ to read

A.o. with the following message:

Error while running background job (class: OCA\\Files_Sharing\\DeleteOrphanedSharesJob, arguments: )","userAgent":"--","version":"","exception":{"Exception":"OC\\DB\\Exceptions\\DbalException","Message":"An exception occurred while executing a query: SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction"

Doesn’t look good to me

Well, I did now follow your flow @OliverV . Upgraded tot 23.0.8 first, and from there I went to 24.0.3.

However, I don’t think it was the actual problem. I suspect that the problem was that I upgraded Nextcloudpi to the most recent version, and immediately upgraded Nextcloud afterwards without restarting the CLI.

Anyhow, I am on 24.0.3 now. Thanks all for thinking along.