Upgrading from 13.0.6 to 14.0.1


I have run the update and it has failed and I now can’t logon at all. It says Exception: Updates between multiple major versions and downgrades are unsupported. How can I resolve this as I cant downgrade and it won’t run the update.

Thank you

I have disabled all apps via command line but it will still not upgrade. Is there anyway of getting round this?

I am after solution not to be spammed by offering online casino.

Can you check the version.php file in your main folder, and also the version in your config.php?

You are sure that you were running NC 13 and not 12? If you are not sure, I’d delete everything except the data folder and config folder, place the code from NC 13.0.6 and run occ upgrade. In case it was NC 12, it will upgrade properly, in case it was NC 13.0.6 already, it doesn’t do anything. Or you revert to your backup you have done before and check the setup (perhaps a previous update did not run properly?).

Thanks you for your reply. I will see if I can find this info for you. It was definitely on 13.0.6 before and it flagged up in NC to upgrade to 14.0.1. I am not familiar with all the command lines as I use to just run a sh file to run the update. What command would I run to find out the config & php version?

$CONFIG = array (
  'instanceid' => '
  'passwordsalt' => 
  'secret' => 
  'trusted_domains' =>
  array (
    0 => '',
    1 => 
    2 => 
  'datadirectory' => '/CloudDATA',
  'overwrite.cli.url' => '',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',

Your config says that it is still NC 12.0.2. So then perhaps a previous update didn’t run properly and not everything was updated. I’d use then NC 13.0.6 code and run all the update procedures again to make sure that the database and everything is really up to NC 13.0.6 before going to NC 14.