Upgrade to version 28 causes ongoing error in logs

After upgrading to version 28, I keep getting error messages in log whenever I click the administration pulldown. As far as I can tell, this didn’t happen on previous version.
The raw error message is as follows:-
{“reqId”:“dx6bO0Q48BeiTOyIrcG6”,“level”:3,“time”:“2024-01-18T05:42:45+00:00”,“remoteAddr”:“”,“user”:“test”,“app”:“index”,“method”:“GET”,“url”:“/data/.ocdata?t=1705556565273”,“message”:“The requested uri(/data/.ocdata) cannot be processed by the script ‘/nextcloud/index.php’)”,“userAgent”:“Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:121.0) Gecko/20100101 Firefox/121.0”,“version”:“”,“exception”:{“Exception”:“Exception”,“Message”:“The requested uri(/data/.ocdata) cannot be processed by the script ‘/nextcloud/index.php’)”,“Code”:0,“Trace”:[{“file”:“/var/www/nextcloud/lib/base.php”,“line”:1007,“function”:“getRawPathInfo”,“class”:“OC\AppFramework\Http\Request”,“type”:“->”},{“file”:“/var/www/nextcloud/index.php”,“line”:39,“function”:“handleRequest”,“class”:“OC”,“type”:“::”}],“File”:“/var/www/nextcloud/lib/private/AppFramework/Http/Request.php”,“Line”:732,“message”:“The requested uri(/data/.ocdata) cannot be processed by the script ‘/nextcloud/index.php’)”,“exception”:,“CustomMessage”:“The requested uri(/data/.ocdata) cannot be processed by the script ‘/nextcloud/index.php’)”},“id”:“65a8bab055202”}


Everything appears to work correctly for both normal and administrative users.
The exception is thrown in :-
which looks like

// strip off the script name’s dir and file name
// FIXME: Sabre does not really belong here
[$path, $name] = \Sabre\Uri\split($scriptName);
if (!empty($path)) {
if ($path === $pathInfo || str_starts_with($pathInfo, $path . ‘/’)) {
$pathInfo = substr($pathInfo, \strlen($path));
} else {
throw new \Exception(“The requested uri($requestUri) cannot be processed by the script ‘$scriptName’)”);


Any help appreciated, this is annoying but not critical.


Please fill out the standard template when posting. We need:

  • Web server
  • Proxy server
  • Installation method
  • Update method
  • occ config:list system output

Hi @kimbo, have you tried to clear your browser cache?
Stop and restart any caching software on your server ( like php-fpm, opcache and more) ?

Skip to main content
Server configuration detail

Operating system: Linux 6.5.0-14-generic #14-Ubuntu SMP PREEMPT_DYNAMIC Tue Nov 14 14:59:49 UTC 2023 x86_64

Webserver: Apache/2.4.57 (Ubuntu) (apache2handler)

Database: mysql 10.11.4

PHP version: 8.2.10-2ubuntu1

Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, json, random, Reflection, SPL, session, standard, sodium, apache2handler, mysqlnd, PDO, xml, apcu, bcmath, bz2, calendar, ctype, curl, dom, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, iconv, imagick, intl, exif, mysqli, pdo_mysql, Phar, posix, readline, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, xmlreader, xmlwriter, xsl, zip, Zend OPcache

Nextcloud version: 28.0.1 -

Updated from an older Nextcloud/ownCloud or fresh install:

Where did you install Nextcloud from: unknown

<details><summary>Signing status</summary>


<details><summary>List of activated apps</summary>

 - activity: 2.20.0
 - calendar: 4.6.3
 - circles: 28.0.0-dev
 - cloud_federation_api: 1.11.0
 - comments: 1.18.0
 - contacts: 5.5.1
 - contactsinteraction: 1.9.0
 - dashboard: 7.8.0
 - dav: 1.29.1
 - federatedfilesharing: 1.18.0
 - federation: 1.18.0
 - files: 2.0.0
 - files_pdfviewer: 2.9.0
 - files_photospheres: 1.28.0
 - files_reminders: 1.1.0
 - files_sharing: 1.20.0
 - files_trashbin: 1.18.0
 - files_versions: 1.21.0
 - firstrunwizard: 2.17.0
 - logreader: 2.13.0
 - lookup_server_connector: 1.16.0
 - mail: 3.5.4
 - maps: 1.3.1
 - memories: 6.2.2
 - nextcloud_announcements: 1.17.0
 - notes: 4.9.2
 - notifications: 2.16.0
 - oauth2: 1.16.3
 - password_policy: 1.18.0
 - photos: 2.4.0
 - previewgenerator: 5.4.0
 - privacy: 1.12.0
 - provisioning_api: 1.18.0
 - recommendations: 2.0.0
 - related_resources: 1.3.0
 - richdocuments: 8.3.1
 - richdocumentscode: 23.5.702
 - serverinfo: 1.18.0
 - settings: 1.10.1
 - sharebymail: 1.18.0
 - support: 1.11.0
 - survey_client: 1.16.0
 - systemtags: 1.18.0
 - text: 3.9.1
 - theming: 2.3.0
 - twofactor_backupcodes: 1.17.0
 - twofactor_email: 2.7.4
 - updatenotification: 1.18.0
 - user_status: 1.8.1
 - viewer: 2.2.0
 - weather_status: 1.8.0
 - workflowengine: 2.10.0
 - admin_audit
 - bruteforcesettings
 - encryption
 - files_external
 - files_rightclick: 1.6.0
 - openotp_auth
 - spreed: 18.0.1
 - suspicious_login
 - twofactor_totp
 - user_ldap


<details><summary>Configuration (config/config.php)</summary>

    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "http:\/\/localhost\/nextcloud",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "maintenance": false,
    "theme": "",
    "loglevel": 2,
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpmode": "smtp",
    "mail_sendmailmode": "smtp",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpauth": 1,
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "587",
    "default_language": "en",
    "default_locale": "en_AU",
    "default_phone_region": "AU",
    "default_timezone": "Australia\/Sydney",
    "memcache.local": "\\OC\\Memcache\\APCu",
    "opcache.interned_strings_buffer": "16",
    "opcache.jit": "1255",
    "opcache.jit_buffer_size": "128M",
    "memories.exiftool": "\/var\/www\/nextcloud\/apps\/memories\/bin-ext\/exiftool-amd64-glibc",
    "memories.vod.path": "\/var\/www\/nextcloud\/apps\/memories\/bin-ext\/go-vod-amd64",
    "enabledPreviewProviders": [
    "memories.vod.disable": false,
    "memories.vod.ffmpeg": "\/usr\/bin\/ffmpeg",
    "memories.vod.ffprobe": "\/usr\/bin\/ffprobe",
    "memories.gis_type": 1,
    "twofactor_enforced": "false",
    "twofactor_enforced_groups": [],
    "twofactor_enforced_excluded_groups": []


Cron Configuration: Array
[backgroundjobs_mode] => cron
[lastcron] => 1705659304

External storages: files_external is disabled

Encryption: no



Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:121.0) Gecko/20100101 Firefox/121.0

Nextcloud – a safe home for all your data

Get your own free account

I originally installed using the web installer, and have updated twice using the web-updater for minor versions. This is the first update of a major version. Perhaps I should scrub it and start again, although that would be a pain if it is indeed just a simple problem with a simple solution.
Thanks for the attention.

I have cleared the browser cache and have also accessed the server from a clean machine that has never been used for browsing. Each still gives the same result.

How do I clear the opcache?

I’ve cleared the opcache with opcache gui and cli (php -r ‘opcache_reset();’ )and still the same result.

@kimbo try to restart apache (or nginx . depending of your installation)

Yep, restarted just about everything (esp. apache2), including remote host that accesses site. Also restarted (many times) the host server. Still the same.

I decided to install a clean installation on another machine with LTS Ubuntu version and latest nextcloud - still having similar problems in logs, though not fully configured yet.

I’ve done a clean install on new server, error now DOES NOT occur. (I have plenty of other configuration errors to correct, however)

FYI - in the new installation, the file ‘apps/photos/js/photos-sidebar.js’ shows up in the integrity scan as invalid, so I’ve downloaded a new version from github. This file has the correct/expected sha512sum hash, and I then did ‘occ integrity:check-app photos’ and the error has gone.

1 Like