Upgrade to NC 12 : No more background image


I’m facing issue since I upgraded NC from 11 to 12.
I have no more background image on my login page and some logos are not loaded as well when i’m logged in.

I read all of the topics about that issue, like those ones :

I have a reverse proxy so I tried everything with the differents options I read like overwriteprotocol, overwrite.cli.url, overwritecondaddr, trusted_proxies options but sill that issue on every browsers :

Content Security Policy: The page’s settings blocked the loading of a resource at http://xxx.xxx.xxx/index.php/apps/theming/loginbackground?v=1 (“img-src https://xxx.xxx.xxx data: blob:”). (unknown)
Content Security Policy: The page’s settings blocked the loading of a resource at http://xxx.xxx.xxx/core/img/logo.svg?v=1 (“img-src https://xxx.xxx.xxx data: blob:”).

I also tried to bypass my reverse proxy but sill same issue.

So right now I just don’t know what else I could do.

Here is my config.php file :

<?php $CONFIG = array ( 'instanceid' => 'xxxxxxxx', 'passwordsalt' => 'xxxxxxxx', 'secret' => 'xxxxxxxxxxxxxxxxxxxxx', 'overwriteprotocol' => 'https', 'overwrite.cli.url' => 'https://mynextcloud.example.com', 'trusted_domains' => array ( 0 => 'mynextcloud.example.com', ), 'trusted_proxies' => array ( 0 => 'xxx.xxx.xxx.xxx', ), 'datadirectory' => '/var/www/nextcloud-data', 'overwritecondaddr' => "^xxx\\.xxx\\.xxx\\.xxx$", 'dbtype' => 'mysql', 'version' => '', 'dbname' => 'xxxxxxxxxxx', 'dbhost' => 'xxxxxxxxxx', 'dbport' => '', 'dbtableprefix' => 'oc_', 'dbuser' => 'xxxxxxxxxxx', 'dbpassword' => 'xxxxx', 'installed' => true, 'appstore.experimental.enabled' => true, 'filelocking.enabled' => true, 'memcache.local' => '\\OC\\Memcache\\Redis', 'memcache.locking' => '\\OC\\Memcache\\Redis', 'memcache.distributed' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => '/var/run/redis/redis.sock', 'port' => 0, 'timeout' => 0.0, ), 'loglevel' => 2, 'logtimezone' => 'Europe/Paris', 'log_rotation_size' => '104857600', 'maintenance' => false, 'mail_smtpmode' => 'smtp', 'mail_from_address' => 'xxxxxx', 'mail_domain' => 'example.com', 'mail_smtphost' => 'smtp.example.com', 'mail_smtpport' => '25', );

If anyone could help me about this.


Silly question perhaps, but have you restarted Apache?

I restarted everything I could :slight_smile:

I wonder if it could be caching via Redis? Otherwise not sure; the changes you’ve made should be more than enough.

For some strange reason it’s working when using a real SSL cert and a domain. I had the same issues on teh Nextcloud VM when accessing it locally (LAN) but when using a domain and SSL it works.


I tried to restart redis but nothing changed.

Otherwise I already have a real SSL cert (let’s encrypt) and real domain known on the internet.


My nextcloud instance is hosted on a VM with Openstack, do you think it could be related to this?

Hi again,

I just realized that in my backed up configuration I had this into my config.php :

‘overwrite.cli.url’ => ‘http://mynextcloud.example.com’,

Now I do have “https” as you can see on my first comment but doesn’t work, still have a blue screen

I fixed my issue.

I found out that the trouble was coming from the theming app. So I first tried to disable it and by doing this the images were back, I had my backgroung image on the login page and all of the logos.

So then, I deleted the theming repository and re-downloaded it and now everything is good.

I made a backup of my previous theming repository but so far I didn’t find anything different.