Upgrade to 18.0.14 hangs

I started the Nextcloud update from version 18.0.4 to 18.0.14 in the admin section of the UI.

After some minutes it said that the update was successful and that I’m going to be redirected to my Nextcloud. But then I ended up again in the “Start update” screen:

No matter how often I press “Start update” and the update succeeds, NC always sends me back to “Start update” screen.

What can I do now to get my Nextcloud instance running again?

Some additional information:

update.log ends with:
2021-04-15T21:49:42+0200 9ZmUOZ2LXm [info] POST request for step “12”
2021-04-15T21:49:42+0200 9ZmUOZ2LXm [info] startStep(“12”)
2021-04-15T21:49:42+0200 9ZmUOZ2LXm [info] finalize()
2021-04-15T21:49:42+0200 9ZmUOZ2LXm [info] storage location: /nextcloud/data/updater-ockhzs1jd4tx/downloads/nextcloud/
2021-04-15T21:49:42+0200 9ZmUOZ2LXm [info] call opcache_reset()
2021-04-15T21:49:42+0200 9ZmUOZ2LXm [info] end of finalize()
2021-04-15T21:49:42+0200 9ZmUOZ2LXm [info] endStep(“12”)

Content of .step-previous-update File is:

maintenance in config.php is set to false.

Output of php status.php is (the “[needsDbUpgrade] => 1” may is suspicious):
[installed] => 1
[maintenance] =>
[needsDbUpgrade] => 1
[version] =>
[versionstring] => 18.0.14
[edition] =>
[productname] => name
[extendedSupport] =>

Hi @dankito,
If you have .step and .step-previous-update file, please delete them or move them to other folder ( for backup, if you want ).
See this : Upgrade screen 20→21 shows confusing info and does not start upgrade - #11 by artfulrobot

Thanks for your answer @Mageunic. But I don’t think that’s the issue in my case.

There are no .step files in updater-xxx/backup.

Only one .step-previous-update file in updater-xxx. But also renaming or moving it doesn’t help.

Any other ideas why NC is still showing the “Start update” screen?

Just saw in the browser console this error:

Content Security Policy: The page’s settings blocked the loading of a resource at data: (“media-src”).

Is that may a hint or is it rather misleading?

@dankito maybe but I have no idea…
the update has been done and the page is still displayed or the update is not done ?

Hi @Mageunic,
the update is done.

For example i get a “update successful” message and the content of .step-previous-update file is:

And status.php says, that version is now 18.0.14:
[version] =>

@dankito have you try this command? ( sudo -u www-data php /var/www/nextcloud/occ maintenance:repair )

Yes, I already did, but no change.

To be on the safe side I ran it again. As I don’t have sudo rights on my webspace I ran in my nextcloud folder:
php occ maintenance:repair

Here is the output:

Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade

  • Repair MySQL collation
    • All tables already have the correct collation → nothing to do
  • Repair mime types
  • Clean tags and favorites
    • 0 tags of deleted users have been removed.
    • 0 tags for delete files have been removed.
    • 0 tag entries for deleted tags have been removed.
    • 0 tags with no entries have been removed.
  • Repair invalid shares
  • Move .step file of updater to backup location
  • Fix potential broken mount points
    • No mounts updated
  • Add log rotate job
  • Clear frontend caches
    • Image cache cleared
    • SCSS cache cleared
    • JS cache cleared
  • Clear every generated avatar on major updates
  • Add preview background cleanup job
  • Queue a one-time job to cleanup old backups of the updater
  • Cleanup invalid photocache files for carddav
  • Add background job to cleanup login flow v2 tokens
  • Remove potentially over exposing share links
    • No need to remove link shares.
  • Clear access cache of projects
  • Switches from deprecated “production” to “stable” update channel
  • Sets the enterprise logo
    • Repair step already executed
  • Reset generated avatar flag
  • Update name of the stored view
  • Fix component of birthday calendars
    • 4 birthday calendars updated.
  • Regenerating birthday calendars to use new icons and fix old birthday events without year
    • Repair step already executed
  • Fix broken values of calendar objects
    0 [>---------------------------]
  • Registering building of calendar search index as background job
    • Repair step already executed
  • Registering background jobs to update cache for webcal calendars
    • Added 0 background jobs to update webcal calendars
  • Registering building of calendar reminder index as background job
    • Repair step already executed
  • Clean up orphan event and contact data
    • 0 events without a calendar have been cleaned up
    • 0 properties without an events have been cleaned up
    • 0 changes without a calendar have been cleaned up
    • 0 cached events without a calendar subscription have been cleaned up
    • 0 changes without a calendar subscription have been cleaned up
    • 0 contacts without an addressbook have been cleaned up
    • 0 properties without a contact have been cleaned up
    • 0 changes without an addressbook have been cleaned up
  • Remove activity entries of private events
    • Removed 0 activity entries
  • Fix the share type of guest shares when migrating from ownCloud
  • Copy the share password into the dedicated column
  • Set existing shares as accepted
  • Update OAuth token expiration times
  • Repair Passwords Database Objects
    • Checking 0 tag revisions
      0 [>---------------------------]
    • Fixed 0 tag revisions
    • Checking 3 folder revisions
      3/3 [============================] 100%
    • Fixed 0 folder revisions
    • Checking 55 password revisions
      55/55 [============================] 100%
    • Fixed 0 password revisions
    • Checking 0 tag models
      0 [>---------------------------]
    • Fixed 0 tag models
    • Checking 3 folder models
      3/3 [============================] 100%
    • Fixed 0 folder models
    • Checking 19 password models
      19/19 [============================] 100%
    • Fixed 0 password models
    • Checking 0 password tag relations
      0 [>---------------------------]
    • Fixed 0 password tag relations
  • Create help command
  • Invalidate access cache for projects conversation provider
    • Invalidation not required
  • Switches from default updater server to the customer one if a valid subscription is available
    • Repair step already executed
  • Add background job to check for backup codes
  • Populating added database structures for workflows

@dankito I don’t know how to solve your issue …

Can you run the upgrade through the command line as well:
php occ upgrade

Also did this before.

Executed command again and console output ends with:
Checking for update of app workflowengine in appstore
Checked for update of app “workflowengine” in appstore
Update successful
Turned off maintenance mode
Reset log level

This command executed really fast, took approximately 1 - 2 seconds. I guess this is due to there’s no update file anymore in data/updater-xyz/downloads.

Then go to the login page. If it still says something about updates, run the terminal command again (not via web-interface).

If that doesn’t change, run it again but add this time a bit more logging to get an idea what might go wrong (normally it should show up, perhaps good to check the logs as well):
php occ -vvv upgrade