Upgrade to 14.0.1

Updater error in 14.0.1
Stuck on deleting old files… updater hangs

Sorry to hear you’re facing problems :slightly_frowning_face:

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2):
Operating system and version (eg, Ubuntu 17.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:


@Fred_Dresken_Maveric I’ve had a similar issue and the details at my end have been like this:

I’m hosting 4 Nextcloud installations and ran my Ansbile playbook to update on one of those first which went through smoothly. Then a ran the playbook on all 4 simulatiously and it hang on the other 3 when running the occ upgrade task. From the console I was able to fetch the output which stated that upgrade was waiting for cron to finish but there was no cron running at all.

I’ve canceled the tasks and tried running occ upgrade manually with the same output running in an infinite loop. I then tried to run cron.php which finished immediately.

On GitHub I then found a hint to run this SQL query: UPDATE oc_jobs SET reserved_at=0; and then a ran occ upgrade again which worked nicely through the tasks as expected.

How I got into this scenario? I don’t know but I have an idea: while I deployed the new code (update from 14.0.0 to 14.0.1) and before the task with occ upgrade got started, maybe the system cron cicked in and ran cron.php which then left a value in that DB table where that column was non-zero and from that on the other tasks ran in a circle.


2 minutes after the error I ran ‘retry update’ in the updater app and everything went smoothly, as always :wink: