Upgrade php to 7.3 error

Hello Forum!
I needed to upgrade my php version 7.0.33 to at least 7.2 - I picked 7.3. I followed those steps https://ayesh.me/Ubuntu-PHP-7.3.
I am using a Turnkey solution on my Proxmox server ( based on debian ).
Although I updated all the packages and diff /etc/php/7.0/mods-available/ /etc/php/7.3/mods-available/ gives me no “Only in 7.0…” I’d get an error.
When opening Nextcloud on the Web, I get:

  • Your webserver seems to be not configured to use PHP or PHP is not installed.
  • Please contact your administrator or follow our documentation:
  • https://docs.nextcloud.com/server /15/admin_manual/installation/source_installation.html


require_once DIR . ‘/lib/versioncheck.php’;

try {

require_once __DIR__ . '/lib/base.php';


} catch(\OC\ServiceUnavailableException $ex) {
\OC::$server->getLogger()->logException($ex, array(‘app’ => ‘index’));

//show the user a detailed error page
OC_Template::printExceptionErrorPage($ex, 503);

} catch (\OC\HintException $ex) {
try {
OC_Template::printErrorPage($ex->getMessage(), $ex->getHint(), 503);
} catch (Exception $ex2) {
try {
\OC::$server->getLogger()->logException($ex, array(‘app’ => ‘index’));
\OC::$server->getLogger()->logException($ex2, array(‘app’ => ‘index’));
} catch (Throwable $e) {
// no way to log it properly - but to avoid a white page of death we try harder and ignore this one here

	//show the user a detailed error page
	OC_Template::printExceptionErrorPage($ex, 500);

} catch (\OC\User\LoginException $ex) {
OC_Template::printErrorPage($ex->getMessage(), $ex->getMessage(), 403);
} catch (Exception $ex) {
\OC::$server->getLogger()->logException($ex, array(‘app’ => ‘index’));

//show the user a detailed error page
OC_Template::printExceptionErrorPage($ex, 500);

} catch (Error $ex) {
try {
\OC::$server->getLogger()->logException($ex, array(‘app’ => ‘index’));
} catch (Error $e) {
header(‘Content-Type: text/plain; charset=utf-8’);
print(“Internal Server Error\n\n”);
print(“The server encountered an internal error and was unable to complete your request.\n”);
print(“Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.\n”);
print(“More details can be found in the webserver log.\n”);

	throw $ex;
OC_Template::printExceptionErrorPage($ex, 500);


Anybody knows what I have to do?
Thank you!

Just to avoid misunderstandings on my side: you checked, that all PHP modules are installed for PHP7.3 as well and all required modules are enabled for PHP7.3, right?
At least for me and a few other users here, the update of PHP required to installed all required PHP modules again (php-zip, xmlwriter and all that stuff mentioned in the install guide).
A few important modules may be missing.

Please also check, that the required modules are not only installed, but also enabled.

Thank you! It works now. I installed all packages again and did a2enmod php7.3 after removing all php7.0 packages and php7.0 itself.

I thought php7.0 was the problem, so the web updater under the settings wouldn’t show up to me (wanting to update to nc16). Sadly the problem consists.

EDIT: It actually worked. The trick was:

It could take up to 30 minutes until the check is executed. To force the check, switch to a different update channel, wait for the “Channel updated” message and switch back to the original channel. The available update should then be visible after a page refresh.

1 Like