Upgrade 24.0.4 to 24.0.5 Collabora online stopped in browser

Hi, maybe I am too eager to get it up and running to thoroughly look through all earlier topics for answers. Sorry if so

I upgraded my perfectly working NC24.0.4 to 24.0.5, and suddenly I can’t open office docs using my standalone Collabora Online anymore. Only download seems to work in my browser.

I don’t really know where to start troubleshooting. The settings page tells me everything is working, and my Collabora server is green.

Anyone with the same experience that found a solution?

Done some simple troubleshooting. The sniffer tells me the NC does not even try to contact the Collabora server when opening a document. If I reconfigure NC Office app, the NC connects for setting up, looking good. Seems to be something with the NC setup (as I guessed from the start)

Any settings that changed between NC24.0.4 and 24.0.5?



I have the same version as you and a standalone Collabora Online code and everything works fine here.

Something must have gone wrong during the update.
Have verify if the application is still enable after the update and if it’s upto date ?
If everything is fine Have you look into your log file ?

Lastly, You can uniinstall the app on Nextcloud and install it again.

Hi Ligal, thanks for answering, much appreciated :slight_smile:

Yes, installation is verified, and the Nexcloud office app has been removed and installed again. I am a bit troubled by the fact that when the app is configured, and the collabora server is initiated, network traffic is sent between the servers, but when a client is supposed to open a document it’s quiet. It seems the browser doesn’t even try.

No interesting things in the logs, NC log, syslog or firewall log, in neither machine…

When you said you had done sniffers, are you referring to the sniffer of your navigator ?
That could tell if your web browser is sending a request to your Collabora server.

Sniffer = network sniffer :slight_smile:

The browser do not send a request to the Collabora online server, this is what’s bothering me. The browser won’t even try. And I have tested different browsers on different machines, so there is no old cookie or other stuff to clean out. This is something with the code in NC I think. I am about to reinstall the NC as a next step.

I catched this in the NC logs, but I don’t know if it is related, seems more about the circles app which is now deactivated.

“Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route “contacts.contacts.directcircle” as such route does not exist.”

“Deprecated event type for OCP\IPreview:PreviewRequested: Symfony\Component\EventDispatcher\GenericEvent is used”

Ahhh, found the problem, it is my Collabora Online server that is broken. It was upgraded at the same time. My sniffer filter was wrong, the browser was actually trying to access the collabora server. Reverting back to a backup fixed it, so something went wrong in the upgrade of collabora code. Maybe some new settings needed in the reverse proxy in the collabora server…? Need to investigate more in that.

Lots of thanks for your help @ligal


Nice !

Just to quickly go back to the sniffer. I tried to say : use the devTools in your browser. There is a sniffer here (running only at the browser level). That you have immediately told you that all was fine at the browser level.

Yes, I am just used to use network sniffers from the simple fact that I am a network techie, and this issue is like potato potato :slight_smile:

Anyway, Thanks for your help!