Upgrade 11 to 12 error

could help, other than that everyone having had problems with “expected files” once, seems to suggest deleting those files (if possible) - or at least move them out of where they are to a different location for the upgrade and then move it back…

btw: did you download the recent zip-file before trying to install it via commandline?

1 Like

Hi,

I’d suggest the following steps:

  1. execute the following commands on command line (in last command modify target path as desired)

    chown -R wwwrun:www /srv/www/htdocs/nextcloud
    find /srv/www/htdocs/nextcloud -type f -print0 | xargs -0 chmod 0640
    find /srv/www/htdocs/nextcloud -type d -print0 | xargs -0 chmod 0750
    mv /srv/www/htdocs/nextcloud/search /root/

  2. run web updater again

2 Likes

Perfect, now if it advances except when it indicates that you want to delete the files.

I write the error path

Could not rmdir /srv/www/htdocs/nextcloud/updater/…/apps/dav

Thanks for your help.

Thanks for your help, the link I think does not work.

Hi,

What is the output of

ls -al /srv/www/htdocs/nextcloud/apps/

The question is, why the updater is not able to delete the folder
/srv/www/htdocs/nextcloud/apps/dav

Due to missing permissions (should not be the case when you performed the commands I suggested above) or because this folder is not existing anymore.
If it is no longer existing you could try to create in manually for now (just empty folder) and retry the update.

1 Like

I attached to you a capture with an “ls -la”

If I retry the update it always jumps the same error

How can I create this folder, I do not see the full path has “…” in between?

This is strange. Don’t know what is causing that. Could please have a look at the updater.log and the nextcloud.log if there are more details why that folder can’t be removed or what exactly fails?

I just hope the logs tell us some more.

The folder does exist already. The “..” only means “parent-folder”. So nextcloud/updater/.. is nextcloud/ and therefor
/srv/www/htdocs/nextcloud/updater/../apps/dav
is actually
/srv/www/htdocs/nextcloud/apps/dav

1 Like

I deleted all the folders that I was indicating, and now it indicates another error xDDDD


:slight_smile:

2 Likes

I am progressing step by step and it seems that it is not long.

I hope this is the last xD error!

I do not know where to do what it says with that file.

Okay, we’re getting closer :smiley:
What is the output of

ls -alR /srv/www/htdocs/nextcloud/core/vendor/DOMPurify
1 Like

Well in the end, I had to eliminate all those directories that indicated one by one.

And when it indicates “unlink” perform the steps that you indicated me about the other post

And cool! works.

Now from version 11 I have 13.

Everything works fine except one thing, it tells me to check the “php.ini” configuration and rescan the files.

Change what it tells me in “php.ini” but I guess it does not detect it.

Did you restart “php”?

I think it depends on the webserver you are using, but you need to reload the php settings. For nginx you usually use php-fpm as php handler and need to restart that
systemctl restart php-fpm

I believe for apache you just need to restart apache, after making the changes to the php.ini.

If that doesn’t solve the problem, you might want to look if you edited the right php.ini file (in case you have different php versions running) or if there are other .ini files that contain any configurations, that might overwrite your changes to the php.ini. Let’s say an opcache.ini in the php/config directory.

1 Like

Good Morning,
Good Morning,

I think the error is because it is not able to synchronize with a “cron”

If you look at the message, although this is Spanish, it is indicating that you have not performed any synchronization for 21 hours

I guess we’ll have to fix this first so we can fix the rest.

In the message it says:

The last execution of a job ran 22 hours ago. Something seems to go wrong

Alright. Could you please describe: how did you setup the cron job?
What is the output of

crontab -l -u wwwrun

What happens if you run the defined cron jobs manually?

sudo -u wwwrun <cronjob command>

Could you check the system logs for any message about failing cron jobs?

It does not allow me to do anything with wwwrun and then I can not find the “syslog” file where I think it should be the “cron” log

Screenshot_25

This output just means that you forgot to define the cronjob for Nextcloud :wink:

Execute:

crontab -e -u wwwrun

Enter:

*/15  *  *  *  * php -f /srv/www/htdocs/nextcloud/cron.php > /dev/null 2>&1

Wait 15 minutes and check the admin page again.

1 Like

Thank you so much for everything,

By putting that command in the “cron” you already perform the actions.

The problems with “opcache” are still there, but I’ll see another way to fix it (Restart apache and php and it did not work)

Again, thanks for everything.

@Schmu

very well helped! you’ve been really patient and successful, in the end.
hooooooorraaaaaay
<3

1 Like

Thank you very much @JimmyKater :heart_eyes: :hugs:

2 Likes