Updating to 18.02 Errors

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 18.01
Operating system and version (eg, Ubuntu 17.04): CentOS 8
Apache or nginx version (eg, Apache 2.4.25): Server version: Apache/2.4.37 (centos)
PHP version (eg, 7.1): PHP 7.4.3 (cli) (built: Feb 18 2020 11:53:05) ( NTS )

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

Run: sudo -u apache php /var/www/html/nextcloud/updater/updater.phar

[ ] Verify integrity …PHP Fatal error: Allowed memory size of 2097152 bytes exhausted (tried to allocate 106552408 bytes) in phar:///var/www/html/nextcloud/updater/updater.phar/lib/Updater.php on line 637

Trying to run the command line updater and constantly getting the above.

If I try to use the web based updater I run the command and it gives me the secret string and the text sting, I paste the secret string into config.php, then I paste the text version of the string into the login box on the updater and it prompts me again to run the command.

So I am stuck, the command line version errors out by exhausting PHP and the web based updater does nothing.

Do I just format the VM and start over? Or is there a different option I haven’t found yet?

Also, when you run the command line updater it complains that there is a non-default directory of “log” and it won’t continue. But if you delete that directory, HTTPD won’t load any longer.

Im not sure how to get around the quandary I am currently in.

Increase memory limit for php

memory_limit = 256M
memory_limit = 512M

Restart or Reload Apache2

I kept increasing the value and it wasn’t helping. I had it up to 5GB and same error.

I finally set it to -1 and the upgrade went through.


1 Like