Updating NCP version failed

I tried to update my nextcloudpi version from 1.54.0 to 1.54.4 and it resulted in the following message: [ nc-update ] (Thu Jun 20 21:49:49 EDT 2024)Downloading updatesPerforming - Pastebin.com

I’m still on Debian 11 and Nextcloud version 27.1.6.2

Do I need to update my server to debian 12, then update NextcloudPi version, then update nextcloiud from within NCP (in incremental releases, first to 28, then 29)? Would that be the correct order?

Hi Boggle247,

first I would do a backup. Then remove this cdrom repo from /etc/apt/sources.list.d/raspi.list and try again.
There is no need to do a dist-upgrade manually. The script will do it.
And for your information, NC 28.0.5 is the latest (official) version on NCP at this time.
Also check this issue on GitHub for more hints.

I don’t have a raspi.list in sources.list.d. If it matters, my machine is an intel nuc with an x86_64 processor. Running Debian 11.

Then check /etc/apt/sources.list

Yep I found it there and commented it out. Ncp upgraded successfully. Next I will upgrade Debian to 12, the I’ll update nextcloud to the latest supported version. So for now I’ll mark this as solved. Thanks