Updating from 18.0.12 to 19.0.6 Permission denied

I am trying to update my NC18.0.12 system (which is running perfectly) to 19.0.6
For this I use the web interface using the Admin user account using Overview tab and OpenUpdater button, then button start Update.
It immediately comes back with “Check for write permission” :
The following places can not be written to:
/… etc

Permissions for /var/www/nextcloud are
drwxr-x— 14 root www-data

and permissions for /var/www/nextcloud/updater are
drwxr-x— 2 www-data www-data

Operating system and version is Ubuntu 18.04.5 LTS (bionic)

I have tried doing chmod 777 in a number of directories to no avail, and so have restored the VM to it’s original condition (ie before chmod 777).

Any ideas would be (very very) welcome.

Hi @Andre.bapjg
to be sure, you had done this line: sudo chmod -R 755 /var/www/nextcloud/ ?

Tried sudo chmod -R 755 /var/www/nextcloud/.
Made no difference

@andre.bapjg look this topic maybe it can help you : 18.0.1 to 18.0.3 update - write permission check - #10 by codiflow

www-data is owner of all nextcloud server files ?
( sudo chmod -R www-data:www-data /var/www/nextcloud/ )

Tried your suggestions to no avail.

As to your question regarding owner of nextcloud server files,
/var/www/nextcloud has owner/grp root/www-data
Contents are mixture of root/www-data and www-data/www-data

I floowed sugestions in the link you provided
systemctl edit php-fpm.service yielded No files found for php-fpm.service

Checking software versions, I got :
apachectl -v yielded Apache/2.4.29
php -v yielded PHP 7.2.24-0Ubuntu0.18.04.7

Will try your chmod -R www-data:www-data suggestion a little later .

Thanks for your contribution and will update you.

I ran the command “sudo chown -R www-data:www-data /var/www/nextcloud/” which did the trick.
No file permission problems, and the update went on to the end.

At the end, to the question “Keep Maintenance Mode Active ?”, I answered “No (for usage of the web based updater)” which is my case. This was confirmed by a text message “Maintenance mode will get disabled”.

I then got the “Done with a tick mark” indication with a button “Go back to you nextcloud instance to finish the update”, which I proceeded to click.

I then received a message (in French, as I am using the French version of the software) “Update required. Please use the command line updater as the automatique update is deactivated in config.php”.

Any ideas what to do now

@andre.bapjg i’m frech too.
done this command when you are in nexctloud directory:
sudo -u www-data php occ upgrade

after try to edit config.php in /nextcloud-path/config and delete the line that disable automatique update.
like :
‘upgrade.disable-web’ => false,

Thank you for all the help you have given me. My system is now up and running with the latest version of NC (20.0.4).
I did the following :
sudo -u www-data bash
cd /var/www/nextcloud
php7.2 occ upgrade
php7.2 occ maintenance:mode --off
This got me to NC19.
I then did (I think these commands are specific to www.hanssonit.se who supplied the original VM I am using) :
sudo bash /var/scripts/update.sh minor
sudo bash /var/scripts/update.sh
This got me to NC20.
All seems to be working correctly now.

Again, all my thanks for your help

1 Like