Updater.phar is downloading the 16.0.9 and try to update a 18.0.3 installation with 16.0.9

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 18.0.3
Operating system and version (eg, Ubuntu 17.04): Ubuntu LTS
Apache or nginx version (eg, Apache 2.4.25): 2.4.18
PHP version (eg, 7.1): 7.3.16

The issue you are facing:
when i run updater.phar its showing me installed nextcloud version 18.0.3 but the updater try to download 16.0.9 and install it over the 18.0.3. the installation fails with error that the installed version is newer then the downloaded version.

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

  1. run updater.phar

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'inst_id',
  'passwordsalt' => 'secret',
  'secret' => 'moresecret',
  'trusted_domains' =>
  array (
    0 => 'adress0',
    1 => 'adress1',
    2 => 'adress2',
    3 => 'adress3',
    4 => 'adress4',
    5 => 'adress5',
    6 => 'adress6',
    7 => 'adress7',
    8 => 'adress8,
  'datadirectory' => '/var/lib/nextcloud',
  'dbtype' => 'pgsql',
  'version' => '',
  'overwrite.cli.url' => 'https://our.domain.local',
  'dbname' => 'ourdbname',
  'dbhost' => 'ourdbhostname',
  'dbport' => '',
  'dbtableprefix' => '',
  'dbuser' => 'ourdbusername',
  'dbpassword' => 'ourpassword',
  'installed' => true,
  'ldapIgnoreNamingRules' => 'false',
  'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory',
  'filesystem_check_changes' => '1',
  'mail_domain' => 'ourdomainname.de',
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'localhost',
  'mail_smtpport' => '25',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'share_folder' => '/Eigene Dateien/Geteilte Dateien',
  'skeletondirectory' => '',
  'trusted_proxies' =>
  array (
    0 => 'ip-from-proxy',
  'forwarded_for_headers' =>
  array (
  'maintenance' => true,
  'theme' => '',
  'loglevel' => 2,
  'app_install_overwrite' =>
  array (
    0 => 'bookmarks_fulltextsearch',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => '6379',

The output of your Apache/nginx/system log in /var/log/____:


Well your config file says it is 16.0.5. Probably one of your previous updates didn’t work correctly. Did you try to run the occ update command? Interface and everything is NC 18? What does the code integrity check on your admin page say?
In the main folder, there is a version.php, can you check what version is mentioned inside?

i try to find out, if there is just the old version in your config.php or if perhaps other stuff in previous updates didn’t work and you still use an old version or if not if other things are not correctly set up (db updates).

thank you so much for your reply, i have yesterday tried many differnt ways to find the error. My nextcloud is running in a lxc container which is managed by a puppeteer, and the recipe of the puppeter was wrong this has resetet the config.php to 16.0.5 although 18.0.3 was already installed.
I tried to overwrite the config.php with 18.0.0 and run the updater.phar again and it was successfully.
But i had to correct this in puppet, after i did it it worked well again.
So now my nextcloud is up to date and running fine.
Thanks a lot and happy easter holidays.
Greets Eddie