Updater: Check for write permissions

How do I fix the write permissions needed by Updater?

Check for write permissions

The following places can not be written to:

  • /var/www/nextcloud/updater/…/console.php
  • /var/www/nextcloud/updater/…/.htaccess
  • /var/www/nextcloud/updater/…/version.php
  • /var/www/nextcloud/updater/…/status.php
  • /var/www/nextcloud/updater/…/AUTHORS
  • /var/www/nextcloud/updater/…/cron.php
  • /var/www/nextcloud/updater/…/public.php
  • /var/www/nextcloud/updater/…/.user.ini
  • /var/www/nextcloud/updater/…/index.php
  • /var/www/nextcloud/updater/…/index.html
  • /var/www/nextcloud/updater/…/occ
  • /var/www/nextcloud/updater/…/robots.txt
  • /var/www/nextcloud/updater/…/remote.php
1 Like

Potential Solution:
chown -R www-data:www-data /var/www/nextcloud

But I’m also concerened how “Setting Strong Directory Permissions” conflicts with the above solution.

4 Likes

Just wanted to say think you snake29 this was the question and answer I was looking for. Thank you for keeping it posted.

I had this problem too, but I found the solution in the installation manual:

Enable updates via the web interface

To enable updates via the web interface, you may need this to enable writing to the directories:

setsebool httpd_unified on

When the update is completed, disable write access:

setsebool -P httpd_unified off

https://docs.nextcloud.com/server/latest/admin_manual/installation/selinux_configuration.html

image