Updated to and have internal server error

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): ubuntu 22.04
Apache or nginx version (eg, Apache 2.4.25): apache2
PHP version (eg, 7.4): 7.2

The issue you are facing:
Hello, I just updated to nextcloud version and now can’t log in with the internal sever error. It may be the ID or SSL but everything worked before the update.

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. update

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => 'x',
  'secret' => 'x'
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => 'share.domain.com',
    2 => '192.168.x.x',
  'datadirectory' => '/var/www/nextcloud-data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://192.168.x.x',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'xxx',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'instanceid' => 'xx',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'app_install_overwrite' => 
  array (
    0 => 'files_external_onedrive',

The output of your Apache/nginx/system log in /var/log/____:

[Fri Aug 19 00:01:39.795263 2022] [ssl:warn] [pid 274] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name

[Fri Aug 19 00:01:39.795658 2022] [ssl:warn] [pid 274] AH01909: localhost:12322:0 server certificate does NOT include an ID which matches the server name

[Fri Aug 19 00:01:39.795827 2022] [mpm_prefork:notice] [pid 274] AH00163: Apache/2.4.38 (Debian) OpenSSL/1.1.1n configured -- resuming normal operations

[Fri Aug 19 00:01:39.795833 2022] [core:notice] [pid 274] AH00094: Command line: '/usr/sbin/apache2'

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Symfony\Component\Console\Application",“type”:“->”,“args”:[{“class”:“Symfony\Component\Console\Input\ArgvInput”},{“class”:“Symfony\Component\Console\Output\ConsoleOutput”}]},{“file”:“/var/www/nextcloud/console.php”,“line”:100,“function”:“run”,“class”:“OC\Console\Application”,“type”:“->”,“args”:},{“file”:“/var/www/nextcloud/occ”,“line”:11,“args”:[“/var/www/nextcloud/console.php”],“function”:“require_once”}],“File”:“/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php”,“Line”:111,“CustomMessage”:“Could not boot files_versionsCould not resolve OCA\Files_Versions\Versions\IVersionManager! Class can not be instantiated”},“userAgent”:“–”,“version”:“”}

I tried to create an ssl with nginx proxy manager but it always failed. The cert would say * instead of the share.domain.dom I wanted to use. Is there a way to remove any hint of an old attempt at an SSL cert? Or do I need to add the updater secret to the config file that was created for the update? 
I used the turnkey nextcloud installation to a container so I don't have a docker-compose file.

Solved! I deleted the files_external_onedrive folder in the apps directory and now I could log in with previous credentials.