Updated from 15 to version 17.0.1 on share hosting

Hi, I use from many years NextCloud after migrate from OC.
My instance is installed on shared hosting so no CLI !

Up to nc15, I did like described in “Upgrade manually”.
This time, I read https://docs.nextcloud.com/server/17/admin_manual/maintenance/manual_upgrade.html quite quickly and avoid to first put NC16, so with NC17 files, it says me it is not possible.
So I tried to put back nc16, but I have some error, and same with last NC15.
So I downloaded on my personnal PC (ubuntu18.04 with lamp) my nextclouddata(separated in my installation), put last NC15 in my var/www/html/, dump my online database and put in my lamp, set config.php to work with localhost. It works, so I updated to nc16 then nc17- great step.
Right now, I copy my nc17 from my local PC to shared host, dump database and set config.php back to on line.
And when I am connecting, it shows me " Nextcloud will be updated to version 17.0.1" with “Start Update” button.
Why??, it should be already in nc17 now!
If I click on button, it shows me “Possible CSRF attack” or “Exception: Updates between multiple major versions and downgrades are unsupported.”
I saw some logs in my nextclouddata folder. I tried some update but I can’t solve.

Nota: I have added app calendar, contacts and tasks

You updated with occ command? Or the updater-app via command line?

@tflidd thank for your interest, on my localhost, I updated by run web UI.

Finally, I:

  • setup fresh NC17 on the shared host,
  • dump the empty database,
  • merge my updated complete database with empty one (thank vimdiff),
  • import it,
  • move datas from olddata folder to new one and it is ok now!
    Sometimes I should connect on web client first to update token before reconnect desktop client.