Update stuck "Step 5 is currently in process" -- other solutions don't help!

Nextcloud version (eg, 12.0.2): 16.0.3
Operating system and version (eg, Ubuntu 17.04): ?
Apache or nginx version (eg, Apache 2.4.25): ?
PHP version (eg, 7.1): 7.2

The issue you are facing:
I wanted to update from 16.0.3 to 16.0.6 by clicking the update button. Everything started smooth but the integrity check failed, something with files-rightclick app. This integrity problem was also shown in the admin dashboard. I uninstalled files-rightclick, the warning in admin dashboard was gone, but clicking the update button shows “Step 5 is currently in process. Please reload this page later”.

So far I tried the following, without any effect:

Any ideas? Not in a hurry right now, but some point, I really want to update my Nextcloud X-)

Thank you!


I am linking the only sollution that worked for me in a this situation when upgrading from 18.05 to 18.06 and I got stuck af step 5:

Credits go to @rahlquist

In short (my php version was 7.3)
/etc/php/7.3/cli/php.ini had -1 for memory limit, and it should stay that way
Returning the setting back to -1 this error went away.