Update Issue to new Nextcloud Version with Addon: user_ldap

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.41
PHP version (eg, 7.4): 7.4.3

The issue you are facing:

When i try to Update Nextcloud i get the Error:

Updating <user_ldap> ...
An unhandled exception has been thrown:
Error: Call to undefined method OC\DB\QueryBuilder\QueryBuilder::executeQuery() in /var/www/nextcloud/apps/user_ldap/lib/Migration/GroupMappingMigration.php:56
Stack trace:
#0 /var/www/nextcloud/apps/user_ldap/lib/Migration/Version1130Date20220110154717.php(54): OCA\User_LDAP\Migration\GroupMappingMigration->copyGroupMappingData()
#1 /var/www/nextcloud/lib/private/DB/MigrationService.php(528): OCA\User_LDAP\Migration\Version1130Date20220110154717->preSchemaChange()
#2 /var/www/nextcloud/lib/private/DB/MigrationService.php(426): OC\DB\MigrationService->executeStep()
#3 /var/www/nextcloud/lib/private/legacy/OC_App.php(1012): OC\DB\MigrationService->migrate()
#4 /var/www/nextcloud/lib/private/Updater.php(347): OC_App::updateApp()
#5 /var/www/nextcloud/lib/private/Updater.php(262): OC\Updater->doAppUpgrade()
#6 /var/www/nextcloud/lib/private/Updater.php(134): OC\Updater->doUpgrade()
#7 /var/www/nextcloud/core/Command/Upgrade.php(249): OC\Updater->upgrade()
#8 /var/www/nextcloud/3rdparty/symfony/console/Command/Command.php(255): OC\Core\Command\Upgrade->execute()
#9 /var/www/nextcloud/3rdparty/symfony/console/Application.php(1009): Symfony\Component\Console\Command\Command->run()
#10 /var/www/nextcloud/3rdparty/symfony/console/Application.php(273): Symfony\Component\Console\Application->doRunCommand()
#11 /var/www/nextcloud/3rdparty/symfony/console/Application.php(149): Symfony\Component\Console\Application->doRun()
#12 /var/www/nextcloud/lib/private/Console/Application.php(215): Symfony\Component\Console\Application->run()
#13 /var/www/nextcloud/console.php(100): OC\Console\Application->run()
#14 /var/www/nextcloud/occ(11): require_once('/var/www/nextcl...')

EDIT: Did the Manual Upgrade to 22.2.3, that was my solution.

Has the same error when update from to

let me know if you find any solution to the issue, i haven’t been lucky so far.

Did you update manually?

I tried to updated via commandline, which doesn’t work, i get the error above.

Same problem here with update from command line vom 21.0.7 to 21.0.8.

I’ve opened an Issue on GitHub: https://github.com/nextcloud/server/issues/30944

1 Like

Thanks for opening a Github issue, lets keep this thread alive if possible as i’m sure others will have the same issue.

Hi. Tried this:

  • from cli disabled user_ldap-App
  • finished upgrade via cli and exited maintenance mode
  • vi to updater.log and search for the folder the updater stored the files of 21.0.7
  • tar inside the apps-folder of the backup the old user_ldap-files and move the archive to the current folder and untar it (copy is also a solution ;-))
  • check the ownership
  • enable user_ldap again → worked til here

While trying to login as a normal user I got a message about too many requests so I added the private networks (10, 172.16, 192.168) at the brute force settings and it worked.
Tried a login with a wrong password → denied

Possible workaround?