Update Issue. Step 10 "core/shipped.json is not available"

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.2
Operating system and version (eg, Ubuntu 20.04): Debian 11 bullseye
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.54
PHP version (eg, 7.4): 7.4.33
It’s a personnal server (self-hosted) used for me, family and some friends.

The issue you are facing:
Web update failed at Step 3 and while searching for help, I saw people recommending to delete .step file and starting back with cli.
When using cli for updating, process stops at step 10 (deleting files) with error “core/shipped.json is not available”
I tried to touch a so named file but it blocks at starting of update “unexpected file founded”.
Someone on mastodon suggested to copy update files by hand but I’m unsure it wont break the thing.
OCC command don’t work as updater has deleted it.

Is this the first time you’ve seen this error? (Y/N): No, I made many tries with no success

Steps to replicate it:
from the shell, run

cd /var/www/html/nextcloud/updater
sudo -u www-data php updater.phar

The output of your Nextcloud log in Admin > Logging:
not available anymore, web client is not usable

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '********',
  'passwordsalt' => '*****************',
  'secret' => '**************',
  'trusted_domains' =>
  array (
    0 => 'mydomain.com',
    1 => '192.168.1.*',
    2 => '',
    3 => '192.168.1.localcomputerIP',
    4 => 'localcomputername',
  'trusted_proxies' =>
  array (
    1 => 'localProxy',
  'overwritehost' => 'mydomain.com',
  'overwriteprotocol' => 'https',
  'overwritewebroot' => '',
  'overwritecondaddr' => '^192\\.168\\.1\\.localipproxy$',
  'datadirectory' => '/mnt/NextCloud/nextcloud_data/',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://192.168.1.ip/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '*********',
  'installed' => true,
  'maintenance' => true,
  'theme' => '',
  'loglevel' => 0,
  'default_phone_region' => '+33',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0,
    'dbindex' => 0,
  'updater.secret' => '************',

Thanks in advance for your help.

I added a screen of the issue.

I have sent you a PN hopefully with the correct version of shipped.json . Other people can extract it from the correct Nextcloud release find here. Copy to the correct folder an restart the upgrade.

Thanks for you reply.

I tried putting the file in /var/www/html/nextcloud which i suppose corresponds to “core”

And I have this error at starting update :

Nextcloud Updater - version: v20.0.0beta4-11-g68fa0d4

Current version is 23.0.2.

Update to Nextcloud 23.0.12 available. (channel: "stable")
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-23.0.12.zip
Open changelog ↗

Steps that will be executed:
[ ] Check for expected files
[ ] Check for write permissions
[ ] Create backup
[ ] Downloading
[ ] Verify integrity
[ ] Extracting
[ ] Enable maintenance mode
[ ] Replace entry points
[ ] Delete old files
[ ] Move new files in place
[ ] Done

Start update? [y/N] y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[✘] Check for expected files failed
The following extra files have been found:

Update failed. To resume or retry just execute the updater again.

(I also tried copying the file AFTER the check and I still have the message saying it couldn’t find the file while it is still here)

Problem solved. (the bad way ?)

I made a backup of /var/www/html/nextcloud then I force copied files from zip archive. After that I had to put in place my backup config. Then chmod+x occ and I regained access to occ. I exited maintenance mode and I got “ready to upgrade” web page. I ignored it and prefered a command line occ upgrade which went with error first tries. (had to chown root files that kept vince user instead of www-data and similar issues).
At the end, I had a mysql/mariadb error (max-allowed-packet) that I never had before, I juste increased the limit in my.cnf.
And at least, upgrade started.
I was warned that some plugins would be deactivated due to lack of support.
They’r still here.

It seems all my data is back.