Update issue: extra files have been found, update failed

Hi, I’m facing a nextcloud update issue.
It was installed as a web-app by one click installation: https://www.infomaniak.com/en/create-a-website/cms/nextcloud-hosting
I’m stuck to an old version (16.0.5.1), because the updater complains about extra files:

I used the ssh update to be more verbous:

php updater.phar
Nextcloud Updater - version: v16.0.3-3-ga0c2b25 dirty

Current version is 16.0.5.

Update to Nextcloud 16.0.10 available. (channel: "stable")
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-16.0.10.zip
Open changelog ↗

Steps that will be executed:
[ ] Check for expected files
[ ] Check for write permissions
[ ] Create backup
[ ] Downloading
[ ] Verify integrity
[ ] Extracting
[ ] Enable maintenance mode
[ ] Replace entry points
[ ] Delete old files
[ ] Move new files in place
[ ] Done

Start update? [y/N] y

Info: Pressing Ctrl-C will finish the currently running step and then stops the updater.

[✘] Check for expected files failed
The following extra files have been found:
    .ht******f1itrl.data
    .htaccess.pre-18.0.0
    .ht******.appconfig.php
    index.html.backup.********************************
    index.html.backup.********************************

Update failed. To resume or retry just execute the updater again.

Those extra files aren’t only files by the way, for example ht******f1itrl.data is a directory with all my nextcloud users, and their files:

ht******f1itrl.data/user1$ ls
cache  files  files_trashbin  files_versions  uploads

Could you please help me to update nextcloud without loosing my files and parameters of course?

Thanks for your kind help

it would be nice if you would search the forum for already existing issues similar to yours.

you’ll be surprised to find some dozen solutions on your question.

though: you filed an issue with some needed information. that was well done. :slight_smile:

awww… and it would be nice if you would post the found solution here as an answer… which fould close your thread and earn you a solution :wink:

Hi Jimmy,

Many solutions I had read suggested to delete those extra files or directories, which wouldn’t be a good idea if they contain my users and their datas :slight_smile:

Some others solutions suggest to move those files or directories out of the root folder of nextcloud, to run the update, then move them back in the root folder (if I understood correctly).

I tried but I’m still facing an update issue:

php updater.phar 
Nextcloud Updater - version: v16.0.3-3-ga0c2b25 dirty

PHP Warning:  fopen(/home/clients/***************************************/web/fichiers/.ht******f1itrl.data/updater.log): failed to open stream: No such file or directory in phar:///home/clients/***************************************/web/fichiers/updater/updater.phar/lib/Updater.php on line 1101
Could not open updater.log

So the updater script is complaining when this directory is in the root folder, but complaining too if not there.
How to solve this issue? :slight_smile:
The solution is probably somewhere in the forum, but I haven’t found it yet.

first of all… your user data should definitley not be in that directory (it’s hard to find out which data exactly updater complaint about if you are censoring this information as heavyily).

pls move it away from there (forum knows how to do that) before trying to proceed, permanentley.

after that pls try to update again and in case of failure pls add new errorcodes in their longform again. right now all i can see is a triple “///” somehwere which would, of course, lead to an error

Hi Jimmy,
I didn’t choose the user data directory. It’s automaticaly done by the shared hosting I mentionned earlier.
The censored informations are just random characters. I can of course send them to you in PM, tell me if you need them.
To be sure to understand you correctly, you suggest:

  1. to move permanently the data folder
  2. to find the related forum post to know how to do that
  3. to try again the updater script

About point 2, regarding this post it’s not supported by NC but may be possible by editing config.php and the database (I hope I’ve access to the later):


I’ve seen the documentation suggests to place the data directory outside of the web root:
https://docs.nextcloud.com/server/13/admin_manual/configuration_server/harden_server.html#place-data-directory-outside-of-the-web-root

i’m afraid i dont have as much time as i would need to really get into things here :frowning: sorry for that.

if you really cant move your data directory b/c it’s give by your provider you should look after excluding directories from that check.

as far as i remember there’s a variable you could set in config.php or such.

Hello Stino,

I got the same issue as you with Infomaniak and found the solution.

  1. I moved all my data from the Infomaniak data repository to the existing Nextcloud data directory
  2. I updated the config file in config/config.php by :
  • updating the datadirectory location
  • adding the ‘db-pass’ => ‘xxx’ value which I found in a file generated by Infomaniak at my website root
  1. I’ve deleted the Infomaniak generated file with the db-pass value at the root
  2. I run the update script php updater.phar

Works perfectly well for me.
I hope it helps.

2 Likes

Thank you so much for your update @nobodyzen , it works very well on Infomaniak