Update from 21.0.7 fails - missing update button & unable to get local issuer certificate

I want to update my nextcloud - but it fails. I have tried a lot to run it, but I have less knowlage and also less experiance. I hope you can help.

So, what have I done? I pressed Open Updater.

Info Update 21.0.7 to 21.0.9

And gets this:
Updater canceled

The Website doesn’t load any more content. It still stay white. :disappointed_relieved:

So I tried to update it via terminal/console with

sudo -u www-data php /var/www/html/nextcloud/updater.phar

and gets this:

Linux NxCloud1 4.19.0-18-amd64 #1 SMP Debian 4.19.208-1 (2021-09-29) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.
root@NxCloud1:~# sudo -u www-data php /var/www/html/nextcloud/updater/updater.phar
Nextcloud Updater - version: v20.0.0beta4-11-g68fa0d4

Current version is 21.0.7.

  Could not do request to updater server: SSL certificate problem: unable to get local issuer certificate  

update [--no-backup]

:disappointed: :disappointed_relieved: :disappointed:

What do I think is the problem? I believe there is more than one problem…:

The details above let me think I’ve a problem with my SSL-certificate and a problem with php.
I wanted to test my certificate but I have no idea how. I found some commands like certbot. Because the admin who installed nextcloud on the virtual machine doesn’t installed certbot. I am unsure -should I install it? Currently it isn’t installed. Could it help?

Nextcloud version: 21.0.7
Operating system and version: Debian 4.19.208-1
Apache or nginx version: Apache/2.4.38 (debian)
PHP version: 7.3.33 ( Memory Limit: 2 GB; Max Execution Time: 3600; Upload max size: 500 MB)

This seems to be another problem:
The output of my Nextcloud log in Admin > Logging:

[webdav] Fatal: Sabre\DAV\Exception\ServiceUnavailable: Could not open file at <<closure>>

0. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 85
1. /var/www/html/nextcloud/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
   Sabre\DAV\CorePlugin->httpGet(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})
2. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 472
   Sabre\DAV\Server->emit("method:GET", [Sabre\HTTP\Requ ... }])
3. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 253
   Sabre\DAV\Server->invokeMethod(Sabre\HTTP\Request {}, Sabre\HTTP\Response {})
4. /var/www/html/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php line 321
5. /var/www/html/nextcloud/apps/dav/lib/Server.php line 332
6. /var/www/html/nextcloud/apps/dav/appinfo/v2/remote.php line 35
7. /var/www/html/nextcloud/remote.php line 167
   require_once("/var/www/html/n ... p")

GET /remote.php/dav/files/path/to/file/file.docx
from by 3f5ea250a5f at 2022-07-21T19:48:25+00:00

The output of my config.php file:

$CONFIG = array (
  'instanceid' => 'hash123',
  'passwordsalt' => 'hash',
  'secret' => 'hashhash',
  'trusted_domains' => 
  array (
    0 => '',
    1 => '123-cloud.domain.de',
  'datadirectory' => '/var/www/html/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '123-cloud.domain.de',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextclouddb',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'dbusersalt',
  'dbpassword' => 'dbpasswortsalt',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'default_language' => 'de',
  'default_locale' => 'de_DE',
  'default_phone_region' => 'DE',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'lost_password_link' => 'disabled',
  'updater.secret' => '$%%',
  'updater.release.channel' => 'stable',

Why the certificate is unable to get?
In the daily use I have no certificate errors.
Why the Updater stops?


You can check your ssl cert.

certbot might not be installed but maybe letsencrypt is. there the same.

about the webdav error:
Unless you have a Directory in your users rootdirectory files/path/to/file/ and there is a file file.docx

I doubt it. else this should excist /var/www/nextcloud/data/USERNAME/files/files/path/to/file/file.docx

Your config.php looks fine but somehow your current versions seems to be a docker version to me So i’m not sure how to help you.

Did you try manual upgrade