Update from 20.07 to 20.0.9 -- missing write permissions

Dear all,

I try to update with the installer via Settings.
However the update stops with following message:

Check for write permissions
The following places can not be written to:

    /srv/www/htdocs/nextcloud/updater/../.user.ini
    /srv/www/htdocs/nextcloud/updater/../.htaccess
    /srv/www/htdocs/nextcloud/updater/../AUTHORS
    /srv/www/htdocs/nextcloud/updater/../COPYING
    /srv/www/htdocs/nextcloud/updater/../console.php
    /srv/www/htdocs/nextcloud/updater/../cron.php
    /srv/www/htdocs/nextcloud/updater/../index.html
    /srv/www/htdocs/nextcloud/updater/../index.php
    /srv/www/htdocs/nextcloud/updater/../public.php
    /srv/www/htdocs/nextcloud/updater/../remote.php
    /srv/www/htdocs/nextcloud/updater/../robots.txt
    /srv/www/htdocs/nextcloud/updater/../status.php
    /srv/www/htdocs/nextcloud/updater/../version.php

So I changed the permission of the folder update via chmod 777, so everybody should have access to this folder. Unfortunately this does not help.

However the folder is empty. So I do not know, what to do.
The same error occured when trying to update to 20.0.8

OpenSuse Leap 15.2
Apache
NCloud 20.0.7.

Any suggestion is warmly appreciated.

Many thanks in advance

Best regards

Jörg

Although the last sub directory of the path is “updater”, the following two dots (..) are indicating that the process wants to write data to the directory above “updater”, which is the “nextcloud” directory :wink:

Hey friend, how are you?

I understand that you set the 777 just for testing, but it’s hardly not recommended.

Did you try “chown -R www-data:www-data /srv/www/htdocs/nextcloud/” ?

PS.: Maybe your httpd user/group is “apache:apache”.

PS. 2: Do you have SELinux enabled?

for me … i happend from time to time, that after a major operating system upgrade … the OS did change the owner my data-directory … that’s why … i created a regular check script, which will check (& correct if wrong), owner & permission:

stat -L -c “%a %G %U” /ncdata
chmod 0770 /ncdata
chown your-web-server-owner:your-web-server-owner /ncdata

Dear all,

thanks for your support.
@j-ed, yes that was the solution; I misunderstood the “/…/”.

Now I am happy, that the system is running again.

I changed the permissions for the files listed. The update-process worked, until it should “replace entry points”. At that point it was obviously a comparable problem with the permissions. Nextcloud stopped with the message “update in progress”

So I saved the permissions with

getfacl

in order to reset them at the end of the update process.
Then I changed all permission to 777 and finished the update.

During the update process the permissions are now re-set automatically, so I do not have to changed them again.

Now the system is running and the permissions seem to be set in the correct way (without any action by myself…)

Thanks all for your support.

Best regards.

JS

1 Like

Good morning mate, WOW!

Nice job! Congrats mate!

:smiley: