Update from 17.0.3 to 18.0.0 total freeze - blank page in browser and server isn't available

Update from 17.0.3 to 18

Updater worked fine until i pushed the button to start the web-updater. Updater Log-file shows it stopped after step 12.

Since then the server isn’t available.

Is it possible to restart the update-process?

thanks in advance

Are you able to log in to your server using SSH?
If so try to restart the upgrade using occ:

cd /path/to/your/nextcloud
sudo -u www-data php occ upgrade -h

Also have a look at this:

welcome to the forum, @Christian3

it’s nice to have you here…

So you ask

and all i could answer was: try it manually… the manual would know how to do that.

sorry i am not clearer here… i just dunno how since you didnt provide any more info/details about your settings, your server, your environment, etc.

i mean you even wrote “server isn’t available” but then ask "

let’s think: if your server isn’t reachable then how would you like to restart your update-process? direct wifi-ing to process?

pls be more precisely in your questions, issues and do give out more infos… awww and using searchfunction of the forum (it’s built-in and comes for free) could be of help as well… i remember i saw something about what to do when updating from 17 to 18…

good luck!

I had the same error, CLI did the upgrade and for me it’s working.

I’m sorry, CLI means clean install?

Oh, you mean command line. The problem is, the Nextcloud instance is installed on a shared server and I have limited SSH access. So far, I’ve obviously been lucky to update via the web interface. Which command could trigger the continuation of the update.

CLI utilities?

Once you are connected:

That should be it.

Hello, since the Nextcloud is installed on a shared system, I have limited possibilities with SSH.
But the CLI command you mentioned has done the update for this server installation of the shared system in the following form:
/usr/bin/php7.3 occ upgrade
and then turn maintenance mode off again and everything is fine.
Thanks a lot!

Hello, I have the same problem, but no SSH on server - only FTP. How can I trigger the continuation in true this (FTP) way?

I had a nextcloud server that was still at 17. Had the exact same issue as above. A 10-second google search found this fix and it worked. Thanks, everyone. Nice was a nice little workout for my heart for a moment :slight_smile: