Update from 11.0.3 to 11.0.4 updates to 12.0.1

Nextcloud version (eg, 10.0.2): 12.0.1 (11.0.3)
Operating system and version (eg, Ubuntu 16.04): 16.04
Apache or nginx version (eg, Apache 2.4.25): 2.4
PHP version (eg, 5.6): 7
Is this the first time you’ve seen this error?: yes

Can you reliably replicate it? (If so, please outline steps): install 11.0.3 update says 11.0.4 updates to 12.0.1

The issue you are facing:
updated to wrong version

Expected: update to 11.0.4 instead to 12.0.1

Using the web updater also resulted in the same in my experience.

Same from my experience. Upgraded to 12.0.1 from the web update. I had a similar question about this. I thought it was the desired behavior, but apparently it is not.

Problem was also discussed here:


with reference to github issue.