Update error from 18.0.3 to 18.0.5 [solved]

Nextcloud version : 18.0.3
Operating system and version : Freebsd
Using nginx

Is this the first time you’ve seen this error? (Y/N) : Yes

The issue you are facing:
Unable to unable to update from 18.0.3 to 18.0.5 using “Updater”. Stuck at updating 18.0.5 process. The page can’t even roll-back to the previous working version 18.0.3. It is by default maintenance turn on but when i use occ command to manually turn maintenance off, it doesn’t lead me to my usual login page but the update page where it halted. when re-try to update i’m getting the same error.

Is this the first time you’ve seen this error? (Y/N): Yes

The output of your Nextcloud log in Admin > Logging:

Error message : 
Exception: sh: ../../tools/allfontsgen: Exec format error
Detailed logs 
Preparing update
Set log level to debug
Turned on maintenance mode
Repair step: Repair MySQL collation
Repair info: All tables already have the correct collation -> nothing to do
Repair step: Repair SQLite autoincrement
Repair step: Copy data from accounts table when migrating from ownCloud
Repair step: Drop account terms table when migrating from ownCloud
Updating database schema
Updated database
Repair step: Rebuild font library
Exception: sh: ../../tools/allfontsgen: Exec format error

Updater Log : 
2020-06-08T17:31:43+0000 bs2UoCSWPd [info] rollbackChanges("5")
2020-06-08T17:31:43+0000 bs2UoCSWPd [info] unlink .step
2020-06-08T17:31:43+0000 bs2UoCSWPd [info] end of  rollbackChanges()
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] request to updater
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] currentStep()
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] POST request for step "5"
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] startStep("5")
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] verifyIntegrity()
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] getUpdateServerResponse()
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] updaterServer: https://updates.nextcloud.com/updater_server/
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] releaseChannel: stable
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] internal version:
2020-06-08T17:37:07+0000 2CJNLbfsIh [info] updateURL: https://updates.nextcloud.com/updater_server/?version=18x0x3x0xxxstablexx2020-03-11T14%3A54%3A25%2B00%3A00+93cae9d2d17112084c882df902b31604151669c0x7x4x5
2020-06-08T17:37:08+0000 2CJNLbfsIh [info] getUpdateServerResponse response: Array
    [version] =>
    [versionstring] => Nextcloud 18.0.4
    [url] => https://download.nextcloud.com/server/releases/nextcloud-18.0.4.zip
    [web] => https://docs.nextcloud.com/server/18/admin_manual/maintenance/upgrade.html
    [changes] => https://updates.nextcloud.com/changelog_server/?version=18.0.4
    [autoupdater] => 1
    [eol] => 0
    [signature] => UZtvzq+6HDxwjG5BYJGA2dXhWXR+pkMxlCVLYicWfLdHNk+Cy9rhbM+wcXD4ihLW

2020-06-08T17:37:08+0000 2CJNLbfsIh [info] storage location: /usr/local/www/nextcloud/data/updater-ocbx1vhcc5vl/downloads/
2020-06-08T17:37:09+0000 2CJNLbfsIh [info] end of verifyIntegrity()
2020-06-08T17:37:09+0000 2CJNLbfsIh [info] endStep("5")
2020-06-08T17:37:09+0000 SyMgLuOgOs [info] request to updater
2020-06-08T17:37:09+0000 SyMgLuOgOs [info] currentStep()
2020-06-08T17:37:09+0000 SyMgLuOgOs [info] Step 5 is in state "end".
2020-06-08T17:37:09+0000 SyMgLuOgOs [info] POST request for step "6"
2020-06-08T17:37:09+0000 SyMgLuOgOs [info] startStep("6")
2020-06-08T17:37:09+0000 SyMgLuOgOs [info] extractDownload()
2020-06-08T17:37:09+0000 SyMgLuOgOs [info] storage location: /usr/local/www/nextcloud/data/updater-ocbx1vhcc5vl/downloads/
2020-06-08T17:37:11+0000 SyMgLuOgOs [info] end of extractDownload()
2020-06-08T17:37:11+0000 SyMgLuOgOs [info] endStep("6")
2020-06-08T17:37:11+0000 v8yvmFWp8N [info] request to updater
2020-06-08T17:37:11+0000 v8yvmFWp8N [info] currentStep()
2020-06-08T17:37:11+0000 v8yvmFWp8N [info] Step 6 is in state "end".
2020-06-08T17:37:11+0000 v8yvmFWp8N [info] POST request for step "7"
2020-06-08T17:37:12+0000 v8yvmFWp8N [info] startStep("7")
2020-06-08T17:37:12+0000 v8yvmFWp8N [info] setMaintenanceMode("true")
2020-06-08T17:37:12+0000 v8yvmFWp8N [info] configFileName /usr/local/www/nextcloud/updater/../config/config.php
2020-06-08T17:37:12+0000 v8yvmFWp8N [info] end of setMaintenanceMode()
2020-06-08T17:37:12+0000 v8yvmFWp8N [info] endStep("7")
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] request to updater
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] currentStep()
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] Step 7 is in state "end".
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] POST request for step "8"
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] startStep("8")
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] replaceEntryPoints()
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] replace index.php
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] replace status.php
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] replace remote.php
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] replace public.php
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] replace ocs/v1.php
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] replace ocs/v2.php
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] end of replaceEntryPoints()
2020-06-08T17:37:12+0000 3N4Qhhkx56 [info] endStep("8")
2020-06-08T17:37:12+0000 xrScJXOIKT [info] request to updater
2020-06-08T17:37:12+0000 xrScJXOIKT [info] currentStep()
2020-06-08T17:37:12+0000 xrScJXOIKT [info] Step 8 is in state "end".
2020-06-08T17:37:12+0000 xrScJXOIKT [info] POST request for step "9"
2020-06-08T17:37:12+0000 xrScJXOIKT [info] startStep("9")
2020-06-08T17:37:12+0000 xrScJXOIKT [info] deleteOldFiles()
2020-06-08T17:37:12+0000 xrScJXOIKT [info] config sample exists
2020-06-08T17:37:12+0000 xrScJXOIKT [info] themes README exists
2020-06-08T17:37:14+0000 xrScJXOIKT [info] end of deleteOldFiles()
2020-06-08T17:37:14+0000 xrScJXOIKT [info] endStep("9")
2020-06-08T17:37:14+0000 tbnLwQqAua [info] request to updater
2020-06-08T17:37:14+0000 tbnLwQqAua [info] currentStep()
2020-06-08T17:37:14+0000 tbnLwQqAua [info] Step 9 is in state "end".
2020-06-08T17:37:14+0000 tbnLwQqAua [info] POST request for step "10"
2020-06-08T17:37:15+0000 tbnLwQqAua [info] startStep("10")
2020-06-08T17:37:15+0000 tbnLwQqAua [info] moveNewVersionInPlace()
2020-06-08T17:37:15+0000 tbnLwQqAua [info] storage location: /usr/local/www/nextcloud/data/updater-ocbx1vhcc5vl/downloads/nextcloud/
2020-06-08T17:37:16+0000 tbnLwQqAua [info] end of moveNewVersionInPlace()
2020-06-08T17:37:16+0000 tbnLwQqAua [info] endStep("10")
2020-06-08T17:37:22+0000 g2u9fepczp [info] request to updater
2020-06-08T17:37:22+0000 g2u9fepczp [info] currentStep()
2020-06-08T17:37:22+0000 g2u9fepczp [info] Step 10 is in state "end".
2020-06-08T17:37:22+0000 g2u9fepczp [info] POST request for step "11"
2020-06-08T17:37:22+0000 g2u9fepczp [info] startStep("11")
2020-06-08T17:37:22+0000 g2u9fepczp [info] setMaintenanceMode("false")
2020-06-08T17:37:22+0000 g2u9fepczp [info] configFileName /usr/local/www/nextcloud/updater/../config/config.php
2020-06-08T17:37:22+0000 g2u9fepczp [info] end of setMaintenanceMode()
2020-06-08T17:37:22+0000 g2u9fepczp [info] endStep("11")
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] request to updater
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] currentStep()
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] Step 11 is in state "end".
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] POST request for step "12"
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] startStep("12")
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] finalize()
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] storage location: /usr/local/www/nextcloud/data/updater-ocbx1vhcc5vl/downloads/nextcloud/
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] call opcache_reset()
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] end of finalize()
2020-06-08T17:37:22+0000 HlsW4ykMJr [info] endStep("12")

I really hope someone could help on this. Looking forward for help.

1 Like


I got same issue, I don’t know what should I do now ?

Hello, same Error message output than richardheng.
Following the suggested upgrade of Community Document Server.
Thank you very much for any help with this, the whole system with calendars and addresses is now down.

Dont update To 18.0.5.
Wait 18.0.6
18.0.5 contains some major bugs

Thank you Bastien. I am stuck with this:

And when I click on the only option “Start Update”, I get this:

I have never asked for a Nextcloud update, I only responded to a Document Server Community upgrade offer.
How can I get out of this please ?

Here’s my status.php output:
Screenshot 2020-06-08 at 23.57.21

Managed to get system back into working order by temporarily disabling documentserver_community app:
sudo -u www-data php occ app:disable documentserver_community

Thanks Dommetz. I did the same like you to disable the document server and re-start the update then it was completed 18.0.5 update successful.

It looks like a bug in the update 18.0.5.

Thanks all for everyone’s sharing. [solved]

Thank you all for sharing, I am glad Richard and I managed to fix this issue.
Our systems are now working again, but with Document Server Community disabled.
If we need this app, we’ll have to wait until the next app’s update and re-install it in order to enable it.

Hello i have the same problem. My installation is on an unraid server with docker.
When i execute the command to disable the plugin i get this error:

Hello Cartaio2009, I am far from being an expert with nextcloud and web servers, and I wish someone more experienced would answer. But in case you are still stuck with your problem, from what I can see you might have to figure out which user runs your web server and might have to replace www-data with the correct user. Here is some information I found online:
" On Ubuntu, both the Nginx and Apache web servers run as the www-data user. On CentOS, Apache runs as apache while Nginx runs as nginx."
Try to find out which user it is in your case and replace it in “sudo -u www-data php occ app:disable documentserver_community”. I hope this helps.

Hello i solved by writing only this:
occ app:disable documentserver_community
On the nextcloud docker therminal In unraid.

Perfect ! Well done Cartaio2909 !


I am linking the only solution that worked for me in a this situation when upgrading from 18.05 to 18.06 and I got stuck af step 5:

Credits go to @rahlquist

In short (my php version was 7.3)
/etc/php/7.3/cli/php.ini had -1 for memory limit, and it should stay that way
Returning the setting back to -1 this error went away.