Update aus Nextcloupi / Cannot load Zend OPcache

Hallo,

ich habe folgendes Problem:
Installiert ist mein Nextcloudpi System (Version 22) auf Rpi4
Ich habe in Vergangenheit öfters schon ohne Probleme von 19 auf 20 etc… über das Nextcloudpi Panel automatisch geupdatet.

Leider habe ich beim letzten Update nicht diese Option genutzt sondern über root Login und dann ncp-update über die Konsole ausgeführt.

Das schlug dann fehl und ich kann neuerdings nicht mehr über das Nextcloudpi Panel updaten
Es erscheint die Fehlermeldung :slight_smile:
“Cannot load Zend OPcache - it was already loaded”

Ich habe gelesen, dass es evtl. mit der PHP Version und Konflikten zu tun hat.
gefunden werden bei mir im System drei PHP Versionen 7.3 / 7.4 und 8.1

Was kann ich jetzt tun um hier wieder Ordnung zu schaffen damit die Update Funktion wieder funktioniert?

hier mal ein Log von

ich will aber auch nicht einfach irgendeine Datei löschen. Zumal die älteste von PHP 8.1 ist…?

root@nextcloudpi:/etc/php# for f in $(find /etc/php/ 2>/dev/null -name “opc”) ; do ls -laFh $f;done
lrwxrwxrwx 1 root root 39 22. Mai 17:21 /etc/php/7.4/fpm/conf.d/10-opcache.ini → /etc/php/7.4/mods-available/opcache.ini
lrwxrwxrwx 1 root root 39 16. Jun 14:50 /etc/php/7.4/fpm/conf.d/20-opcache.ini → /etc/php/7.4/mods-available/opcache.ini
lrwxrwxrwx 1 root root 39 22. Mai 17:21 /etc/php/7.4/cli/conf.d/10-opcache.ini → /etc/php/7.4/mods-available/opcache.ini
lrwxrwxrwx 1 root root 39 16. Jun 14:50 /etc/php/7.4/cli/conf.d/20-opcache.ini → /etc/php/7.4/mods-available/opcache.ini
-rw-r–r-- 1 root root 294 22. Mai 17:23 /etc/php/7.4/mods-available/opcache.ini
-rw-r–r-- 1 root root 313 22. Apr 16:12 /etc/php/8.1/mods-available/opcache.ini

Ausgabe von
root@nextcloudpi:/etc/php# php -v
Cannot load Zend OPcache - it was already loaded
PHP 7.4.33 (cli) (built: Jun 9 2023 16:51:37) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
with Zend OPcache v7.4.33, Copyright (c), by Zend Technologies

Viele Grüße
Jörg

…hier hängt das Update dann fest

Running nc-update-nextcloud
Cannot load Zend OPcache - it was already loaded
Cannot load Zend OPcache - it was already loaded
Current Nextcloud version 22.2.2.0
Available Nextcloud version 23.0.6
Download Nextcloud 23.0.6…
Back up current instance…
Cannot load Zend OPcache - it was already loaded
check free space…

1 Like

Hast du das Problem weiter analysiert oder gar lösen können?
Bei mir sieht es ähnlich aus, nur, dass direkt nach der ersten Fehlermeldung “nextcloud is currently down” erscheint und abbricht.