Update auf NC 21.0.3 - App News meldet

Hallo, habe NC auf Raspberry Pi 4 und Update auf 21.0.3 gemacht; alles durchgelaufen; gestern war nun update für “news” da, und dieses meldet fehler, ich kann auf die NC nicht mehr zugreifen
Fehlermeldung ist: Exception: App “News” cannot be installed because the following dependencies are not fulfilled: 64bit or higher PHP required.
php 7.3 ist installiert
Danke

Kannst Du Dich noch via SSH einloggen?

Falls ja, dann dort mit dem occ Befehl die app deaktivieren.

Gleiches Problem bei mir… Keine Lösung gefunden.
Zunächst gestern Sicherung eingespielt, zurück zur alten App. Heute updatet News automatisch und ich haben den gleichen Fehler…

Detaillierte Protokollmeldungen:

Update vorbereiten

Log-Level auf “debug” gesetzt

Wartungsmodus eingeschaltet

Reparaturschritt: Repair MySQL collation

Reparaturinformation: All tables already have the correct collation → nothing to do

Reparaturschritt: Repair SQLite autoincrement

Reparaturschritt: Copy data from accounts table when migrating from ownCloud

Reparaturschritt: Drop account terms table when migrating from ownCloud

Das Datenbankschema wird aktualisiert

Datenbank aktualisiert

Exception: App “News” cannot be installed because the following dependencies are not fulfilled: 64bit or higher PHP required.

SSH funktioniert, die occ-Befehle aber nicht…

pi@nextcloudpi:~ $ sudo -u www-data php occ app:disable News
Could not open input file: occ

pi@nextcloudpi:~ $ sudo -u www-data php occ app:list
Could not open input file: occ

Du musst schon in dem Verzeichnis sein, wo das occ binary ist.
Und es muss ausführbar sein.

Beim meinem Ubuntu 18.04 ist es /var/www/nextcloud/

Siehe https://docs.nextcloud.com/server/20/admin_manual/configuration_server/occ_command.html#http-user-label

Danke… Beim Weitertüfteln und beim Versuch NC in den Wartungsmodus zu bringen ist mir mein Fehler auch aufgefallen.

Jetzt läuft NC wieder, natürlich ohne News

Danke für die Rückmeldungen; bei Disable von “News” schreibt die Konsole folgendes:

root@raspy4n:/var/www# cd nextcloud/
root@raspy4n:/var/www/nextcloud# sudo -u www-data php occ app:disable News
Cannot load Zend OPcache - it was already loaded
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
No such app enabled: News
root@raspy4n:/var/www/nextcloud#

Guten Morgen; Habe Raspy aus einem Sicherungsimage neu geflasht, News deaktiviert und dann auf 21.0.3 upgedatet. Läuft nun wieder. Danke für eure Hilfe!

Hallo, ich habe die gleiche Fehlermeldung wie buschl.
Beim Versuch News zu deaktivieren erhalte ich folgende Meldung:
root@nextcloudpi:/var/www/nextcloud# sudo -u www-data php occ app:disable News
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
No such app enabled: News
root@nextcloudpi:/var/www/nextcloud#

Hat jemand eine Idee, wie ich die News App deaktivieren kann?
Vielen Dank für eure Meldungen.

Schreib mal den App-Namen klein, also app:disable news
War bei mir der Fehler.

1 Like

Danke für den Tipp sascha224,
war auch bei mir der Fehler.
Jetzt funktioniert NC wieder.

ich bin neu auf der nextcloud und habe im terminal das update durchgeführt. die cloud läuft mit der Meldung : Exception: App “News” cannot be installed because the following dependencies are not fulfilled: 64bit or higher PHP required. auch bei mir nicht.

sudo -u www-data php occ -h

Could not open input file: occ

Hilfe was kann ich tun?

Hallo; probier Tipp von Stef9

sudo -u www-data php occ app:disable News

“News” klein schreiben -
also

sudo -u www-data php occ app:disable news

1 Like