Update 21.0.1 > 21.0.2 problems

Hi, i just tried to upgrade 2 systems to 21.0.2:

  • One raspberry pi. update did run until code integrity chec, them
    gave out an error. Then the rpi froze. When i reboot and quickly
    enough disable the cron.php script, that doesn’t happen. so i
    managed to upgarde to 21.0.2 but as soon i enable cron.php
    again, my memory drains and the rpi begins swapping until its
    frozen again. anyone else hast this problem?

  • on a shared hosting server i get this messages:

    sorry that they are in german. nc won’t update. so whats the reason for that? the mysql version? the memory for php? what else exactly could be upgrade critical? is there a work around for settings on shared hosting servers? please don’t tell me the problems with shared hosting servers. i know them, but the guys runing the server need lot of disk space and don’t have much money.


Hey :),
Last message says indeed that your mysql version is outdated and wouldn’t work with NC21 it’s weird that it worked before no ? xD

yeah it said that AFTER the installation. it’s the same on the other system (the rpi) there it also says that the existing mariadb version wouldn’t be supported while instaliong and running 21.0.1 wasn’t any problem. also installing 21.0.2 was no problem there. so for the shared installation i need to know without any guessing, what exactly blocks the installation, for the other one, why executing cron.php tries to allocate that much memory and how i could circumvent that.

When you search about this issue some says it can be caused by external files (try to desactivate it if you have it). Others are talking about db issue… what’s the return of mysqld --version ?

hi, sorry for the late answer, had lots of work. thank you very much for the kink. mysql-output on the raspberry (actual raspbian distro): mysqld Ver 10.1.38-MariaDB-0+deb9u1 for debian-linux-gnueabihf on armv7l (Raspbian 9.0)

for the actual ubuntu LTS version:
Ver 8.0.25-0ubuntu0.20.04.1 for Linux on x86_64 ((Ubuntu))

on the shared hosting server it is 5.7.33-36

okay that last one is pretty old, that should be checked, but the others?
i think it’s not very smart if nextcloud expects newer versions than in actual distros. if that is the problem. seems no solution in sight?! don’t know what to do now. cron.php doesn’t run anymore on the raspberry. if it does, it tortures memory and mysqld until mysqld crashes. does anyone has a workaround? do i have to live without cron-tasks until there is a nextcloud-update or one for raspbian?? any ideas?

after setting apc.enable_cli=1 in php-ini for cli and apache didn’t work (alone?)

i did find anything i found here,. including getting memcache out of conf.php

in addition i deactivated any additional apps, reinstalled my php-ast because i had some error messages belonging to that. don’t know what exactly it was, but after a reboot nc and cron.php are runing again without freezing the whole system and crashing mysql.
whatever it was what made this upgrade a pain in the ass, it would be great if nc’s upgrade process would be safer, it wouldn’t use any software which doesn’t come with actual repos like debian / raspbian / ubuntu and if it would be able to run on small/older computers in the future.