Unusual problem with /.well-known/caldav

Hello. I encountered an unusual error Your web server is not properly set up to resolve .well-known URLs, failed on: /.well-known/caldav . Not one of the standard solutions to this problem offered by the Nextcloud documentation and the user community It’s not working at the moment, this may be due to the non-standard settings of my Nextcloud home server, since this cannot be implemented otherwise (my providers connected to the server router in the multi-wan do not provide a public IP) (I have attached a diagram of the device for my home network). Not Could you advise me on a way to solve this problem?
(According to my assumption, this may be a problem on the CloudFlare side)