"Unspecified error" when deleiting from one Windows client and syncing on another

[details=“Support intro”]
I have several laptops that sync to each other. Until recently (I wish I could remember when), when I deleted a file from one laptop, Nextcloud would automatically sync, and then the deletion would then propogate to the other laptops.

Now, I get …/fileabc.typ: Unspecified error (please see screenshot). I’ve been trying everything I can to figure out what is going on. I’ve completely blown away an entire Windows install and started all over again, and still the same thing.

At first I thought it was a permissions problem with the folder. I saw that under properties the Nextcloud folder has partially read only, so I tried to remove that. No difference.


For 2 of my laptops, my Nextcloud folder is on an MicroSD card formatted for NTFS, thus D:\Nextcloud.

For my 3rd, it is a folder in my Users directory thus C:\Users\me\Nextcloud.

There are no log entries in my Nextcloud server log whatsoever.

So far, this is only This issue only seems to be about a month old. This was never a problem before.

My Windows client version is 3.11.0 stable. I have to think that I’m not the first person to experience this.

Thank you in advance. I am at wits end!

  • Is that the error on the client you deleted the file from originally or is it the error on one of your other clients?
  • What happens with the deleted file in the Web UI?
  • Have you taken a look at your Desktop client’s debug logs?
  • Are you using VFS?

The errors appear on the other clients.
If I delete it in the Web UI, same error
Here are the relevant entries in the debug logs, but I don’t really understand what this means.

2024-01-17 02:53:28:202 [ info nextcloud.sync.discovery C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\libsync\discovery.cpp:466 ]:	Processing "Downloads/2023-12-31 - Priorities 2024 (1).docx" | (db/local/remote) | valid: true/true/false | mtime: 1705168941/1705168941/0 | size: 100990/100990/0 | etag: "0823b6b5c72a6f82cda0dedc3da38a94"//"" | checksum: "SHA1:9eb0e27ba0ddd51f8e2fa5c2e3e366388b3186a5"//"" | perm: "WDNVR"//"" | fileid: "00254129oc8lsdynug9f"//"" | type: CSyncEnums::ItemTypeFile/CSyncEnums::ItemTypeFile/CSyncEnums::ItemTypeFile | e2ee: false/false | e2eeMangledName: ""/"" | file lock: not locked// | metadata missing: /false/
2024-01-17 02:53:28:202 [ info nextcloud.sync.discovery C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\libsync\discovery.cpp:1627 ]:	"Downloads/2023-12-31 - Priorities 2024 (1).docx 2 2 0"
	Line 21467: 2024-01-17 02:53:30:365 [ info nextcloud.sync.statustracker C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\libsync\syncfilestatustracker.cpp:229 ]:	Investigating "Downloads/2023-12-31 - Priorities 2024 (1).docx" OCC::SyncFileItem::NoStatus CSyncEnums::CSYNC_INSTRUCTION_REMOVE OCC::SyncFileItem::Down
	Line 21486: 2024-01-17 02:53:32:014 [ info nextcloud.sync.propagator C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\libsync\owncloudpropagator.h:220 ]:	Starting CSyncEnums::CSYNC_INSTRUCTION_REMOVE propagation of "Downloads/2023-12-31 - Priorities 2024 (1).docx" by OCC::PropagateLocalRemove(0x2815a37f870)
	Line 21488: 2024-01-17 02:53:32:014 [ info nextcloud.sync.propagator.localremove C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\libsync\propagatorjobs.cpp:102 ]:	Going to delete: "D:/Nextcloud/Downloads/2023-12-31 - Priorities 2024 (1).docx"
	Line 21489: 2024-01-17 02:53:32:066 [ warning nextcloud.sync.propagator C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\libsync\owncloudpropagator.cpp:286 ]:	Could not complete propagation of "Downloads/2023-12-31 - Priorities 2024 (1).docx" by OCC::PropagateLocalRemove(0x2815a37f870) with status OCC::SyncFileItem::NormalError and error: "Unspecified error"
	Line 21490: 2024-01-17 02:53:32:067 [ warning nextcloud.gui.activity C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\gui\tray\usermodel.cpp:878 ]:	Item  "Downloads/2023-12-31 - Priorities 2024 (1).docx"  retrieved resulted in  "Unspecified error"
	Line 21491: 2024-01-17 02:53:32:067 [ warning nextcloud.gui.activity C:\Users\User\AppData\Local\Temp\windows-19197\client-building\desktop\src\gui\tray\usermodel.cpp:840 ]:	Item  "Downloads/2023-12-31 - Priorities 2024 (1).docx"  retrieved resulted in error  "Unspecified error"

Not using VFS

Other relevant info:
Server is rpi4 with the data is on an external drive connected to the rpi4 via USB
Client is a Surface Go with MicroSD mounted as D:.
I reinstalled Nextcloud from the beginning, so it owns the D:\Nextcloud folder.


This continues to be an issue for me. I have some new information from Laptop2 and Laptop3.

3 laptops (let’s call them Laptop1, Laptop2, Laptop3)
Nextcloud directory for Laptop1 is in C:\User\abc\Nextcloud
Laptop2 and Laptop3, the Nextcloud directory is D:\Nextcloud
Otherwise, everything is exactly the same across all 3 computers.

What’s happening
If Laptop1 deletes a file, Laptop2 and Laptop3 gets an “Unspecified Error” and does not delete the file. Instead it shows a red “X”. I can manually delete the file, after which it changes to green and a tick/check mark.

Below is (at least what I think is) the relevant section from the Nextcloud Debug archive.

On the other hand, If Laptop2 deletes a file, Laptop1 also deletes the file, no errors, however Laptop3 has the same “Unspecified error”. This is the same for Laptop3. If Laptop3 deletes a file, Laptop2 has an “Unspecificed error”, Laptop1 is fine.

Laptop2 and Laptop3 are Surface Go 2, Laptop1 is a Lenovo X1.

All 3 computers are setup EXACTLY the same in terms of apps, settings (in Windows, etc.) All 3 computers run the SAME versions of the SAME software. All 3 computers use the same username/password for accessing the server.

The only difference is that Laptop2 and Laptop3 have their Nextcloud directory on an SDcard.

I’ve checked permissions, I’ve checked the disks and the SDcard. I’ve checked (what I think is) everything I can think of.

I honestly don’t remember which version of either the server or the client this started happening.

Last bits of info:
Nextcloud Server:

  • running on RPi 4 (again, it was working perfectly before)
  • Nextcloud version 28.0.1
    Same provblem on Group Shares - Laptop1 works perfectly, Laptop2 and Laptop3 giving “Unspecified error”.

I have (I think) search extensively on Google and in these forums.

Hopefully it is something simple that I have overlooked.

2024-02-05 12:11:54:916 [ info nextcloud.sync.propagator C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\libsync\owncloudpropagator.cpp:1541 ]:	PropagateRootDirectory::slotSubJobsFinished emit finished OCC::SyncFileItem::NormalError
2024-02-05 12:11:54:917 [ info nextcloud.sync.engine C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\libsync\syncengine.cpp:983 ]:	Sync run took  15099 ms
2024-02-05 12:11:54:917 [ info nextcloud.gui.folder C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\gui\folder.cpp:1162 ]:	Client version 3.11.1stable-Win64 (build 20240125)  Qt 5.15.10  SSL  OpenSSL 3.1.3 19 Sep 2023
2024-02-05 12:11:54:917 [ warning nextcloud.gui.folder C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\gui\folder.cpp:1169 ]:	SyncEngine finished with ERROR
2024-02-05 12:11:54:927 [ debug com.nextcloud.owncloudgui C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\gui\owncloudgui.cpp:410 ]	[ OCC::ownCloudGui::slotShowTrayMessage ]:	Going to show notification with title: ' "Sync Activity" ' and message: ' "Downloads\\file1.pdf and 21 other file(s) could not be synced due to errors. See the log for details." '
2024-02-05 12:11:54:948 [ info nextcloud.gui.folder C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\gui\folder.cpp:412 ]:	Folder "" sync result:  OCC::SyncResult::SyncRunning
2024-02-05 12:11:54:948 [ info nextcloud.gui.folder C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\gui\folder.cpp:1198 ]:	the last 4 syncs failed
2024-02-05 12:11:54:950 [ info nextcloud.gui.application C:\Users\User\AppData\Local\Temp\windows-20060\client-building\desktop\src\gui\owncloudgui.cpp:233 ]:	Sync state changed for folder  "https://nc.example.org/remote.php/dav/files/xxxx/" :  "Error"


OK, so here is another update.
On one of my laptops, instead of having the Nextcloud folder being on D:, I moved it to C:\Users\me\Nextcloud, and now everything works.

Has anyone experienced and solved this issue? Surely, I should be able to use D:. My D: is an SDcard that is permanently in my laptop.