Ungewollte Benachrichtigung für Termine

Hallo Zusammen,
ich habe schon länger eine Nextcloud, die ich bei 1Blu hoste.
Funktioniert so weit super.
Seit dem Update auf 28.0.1 bekomme ich über die Nextcloud-App auf meinem Smartphone Benachrichtigen für meine Termine.
Habe noch keine Möglichkeit gefunden das abzuschalten.
Im Nextcloud-Konto sind unter Einstellungen/Benachrichtigen/Kalender, Kontakte und Aufgaben alle Punkte deaktiviert.
Wäre super wenn Jemand einen Tipp für mit hätte.
Vielen Dank!

1 Like

Habe das selbe Problem und hätte gerne eine Lösung und konnte noch keine finden :wink:

Es gibt keine brauchbare Einstellung dafür unter:
settings/user/notifications

Mein Vorschlag wäre es aber genau dort hinzupacken.

Ich dachte schon ich wäre der einzige mit dem Problem.

Ich schliesse mich dem Problem auch an!

Ich hab mal im Github gesucht, aber nix 1:1 gefunden. Es gab ein Bugticket für Web Notifications, da hab ich mich jetzt einfach mal dran gehängt:

Wenn das dort gewünscht ist, erstelle ich ein separates Ticket.

Die Sache nervt mich auch ziemlich. Vor allem am Smartphone, wo ich die Funktion überhaupt nicht nachvollziehen kann.

Die App hat keinen Kalender integriert. Somit muss ich ohnehin eine gesonderte Kalender-App verwenden, die dann eh ihrerseits Terminbenachrichtigungen ausgibt.

Also wofür ist die Benachrichtigung durch die Nextcloud App dann sinnvoll?

Auch am Desktop ist sie mehr störend als nützlich. Abstellen lässt es sich offensichtlich nur durch generelle Deaktivieren von Benachrichtigungen.

1 Like

Zum Glück habe ich diesen Beitrag gefunden! Noch ganz knapp bevor ich verzweifle. :joy: Gleiches Problem, keine Lösung.:roll_eyes:

also ich hab ein paar Neuigkeiten ausm GIT:

Die Änderung ist gewollt mit dieser Änderung reingekommen:

Lösen lässt es sich aktuell nur per OCC:

php occ config:app:set dav sendEventRemindersPush--value=no

und ich hab geschrieben, dass viele (ich z.B.) die occ Zeile vermutlich nicht haben und dafür hoffentlich n Setting kommt… da warte ich seit gestern auf eine Antwort.

PS: gehts euch auch so, dass die Pushes nicht zuverlässig kommen? Ich habe viele Termineinträge und ich würde sagen die Push kommt vielleicht in 10% der Termine und dann gehäuft mit mehreren … also für mich wäre die Funktion auch buggy wenn ich sie nutzen wollen würde.

Danke fürs kümmern!
Wie würde das mit php occ… funktionieren? Per ssh einloggen und dort die Zeile eingeben?
Ich habe auch den Eindruck das die Benachrichtigungen nicht für alle Termine kommen. Aber schon für mehr als 10%.

Ich hab da ehrlich gesagt keine Erfahrung, aber die Anleitung schaut brauchbar aus:

https://docs.nextcloud.com/server/stable/admin_manual/configuration_server/occ_command.html

Vielen Dank! Ich habe den Befehl nun abgesetzt. Mal sehen.

Ob Benachrichtigungen für wirklich alle Termine kommen, kann ich nicht sagen, nachdem die Funktion nur unerwünscht war, aber der Anteil ist gewiss deutlich höher bei mir.

Aufgefallen ist mir allerdings, dass sie ca. 1 Stunde von der Zeit abweichen, vermutlich UTC, aber so genau war das mit der Stunde auch nicht immer.

Ja, und ins Nextcloud Root-Verzeichnis wechseln.

So wie ich es kenne, sind die php Befehle als User auszuführen, unter welchem die Webapplikation läuft. Also bei mir ist das “wwwrun”:
sudo -u wwwrun php occ ...

Das hat einmal nix gebracht.
Ich dachte, ich hätte eine Bestätigung bekommen, dass der Befehl angenommen wurde. Da habe ich aber die Zeile nicht bis zu Ende gelesen. Wozu? War ja ganz hübsch in Grün gehalten, also vermeintlich positiv. :roll_eyes:

Nervende Benachrichtigungen gab es heute dennoch, in der Mobile-App wie am Desktop.

Dann habe ich den Befehl nochmals abgesetzt und die Rückmeldung kritischer betrachtet. Dann sagt sie nichts, wenn auch in Grün:
Config value sendEventRemindersPush--value=no for app dav set to

So habe ich mir den Befehl angesehen. Da fehlt wohl ein Leerzeichen vor --value=no.
Dieses eingefügt, dann wird die Annahme auch bestätigt:
Config value sendEventRemindersPush for app dav set to no

Ich hoffe nun wieder, weniger belästigt zu werden…

Auch die Softwareentwickler können versehentlich Fehler machen und ein Leerzeichen beim Schreiben eines Befehls vergessen. :wink:

Unter dem Lösungsvorschlag steht aber auch ein Link zur generellen Verwendung von occ-Befehlen. Wer also schon häufig verschiedene Befehle abgesetzt hat, der hätte auch diesen Schreibfehler sofort erkannt. :wink:

Der Aufbau dieser Befehle ist immer gleich: occ Befehl --Option

Was mich allerdings stört, das ist, dass diese Befehle in keiner Dokumentation zu finden sind. Ich habe überall danach gesucht und nichts gefunden.

php occ config:app:set dav sendEventRemindersPush --value=no
php occ config:app:set dav sendEventRemindersPush --value=yes

Ergänzung:
Eine Beschreibung dieses Befehls scheint doch schon in Arbeit zu sein.

Das erste, was einer wie ich da macht, ist STRG+c u. STRG+v. Dann kommt eine grüne Rückmeldung und man denkt, alles ist fein.
Hab ich ja alles erklärt.

Offenbar nicht häufig genug, um zu wissen, dass man auch hübsche grüne Rückmeldungen genau lesen sollte. Das gilt hier wohl nicht zwingend als positiv, wie sonst üblich. :wink:

BTW: Bislang war keine Benachrichtigung mehr, obwohl Erinnerungen fällig wären. :slight_smile:
Aber so genau hat es NC ja bisher auch nicht mit dem Erinnerungszeitpunkt genommen. Also, bin weiterhin gespannt.

Danke euch für das abklären und den Fix! Allgemein habe ich den Eindruck das NC28 ziemlich buggy ist. Mal abgesehen von diesem “Bug” hier und von den Erinnerungen die manchmal kommen und manchmal nicht ist sie auch irgendwie träge. Zudem habe ich im Log neuerdings komische Einträge von Apps die vorher nicht da waren. Irgend was von “brauchte zu lange um zu laden”. Langsam sollte ich wissen das man bis zur 3. Version (28.0.3) warten sollte bevor man die Aktualisierung einspielt. :grimacing: Gut, auch das ist keine Garantie… :stuck_out_tongue_winking_eye: