Unexpected error, how to debug?

Hello,

my NC18 has ocr app installed in version 6.0.2

Converted some jpgs yesterday using firefox and it worked.

Today I get the following message after trying to convert:

The nextcloud log does not contain any information regarding the ocr app.

How to get more info?

Has anything changed since yesterday?
This morning my firefox updated to 73.0

Can you look into your Browser console (log). Another idea: delete browser cache or look into the network tab if there is any failed request.

Just did another try and their are errors:

Is it about the language settings?

EDIT:
Had a look at my disk and there is a file called “deu.traineddata.gz” in “appdata…/ocr/tessdata”.

Did some more testing and found out, that admins can convert jpgs.
Works well and output is there.

My user is not an admin and there comes the error.
Both users have same config record in table “oc_preferences”.

Does that help you to find the cause?

You helped me a lot with this!!! I couldn‘t figure out the 403 for days. I will fix this issue, as soon as possible. Please make sure, that when you update the app, you also delete your browser cache, otherwise a wrong traineddata object is saved in the IndexedDB of your browser.

1 Like

Just gave v6.0.3 a try as non-admin.

… and it works ! :partying_face: :firecracker::fireworks:

Thanks for this awesome speed and quality of work.

Related issue at GitHub:

1 Like

Hello,
I have the same issue about the language and I can’t see where I have to put the tessdata directory.
Can you tell me how to resolve the issue.

thanks a lot

See my previous posting.
It was not related to my user settings. The author of the app fixed it.
So which version you are using?

I have NC18 and OCR 6.0.33.

i update OCR to the last version.
Finally, it is working after I cleared the cache of the navigator.