Unclear instruction regarding portforwarding in NC official VM

I am installing NC Official VM on a remote VPS server. Everything went smooth but have 3 points

  1. The isntallation is done on a clean Ubuntu but DHCP is a prerequisite. In my clean Ubintu I was also missing FTP so had to install those things first. Could this be included in the script?

  2. The mariadb root password is shown. The scripts stops for input about installing SSL (yes/no). A number of times I wanted to copy the root password from the SSH window, with the consequence that the script went on as if I did not want to install SSL. It would be nice if the script stopped immediately after the masiadb root password is shown giving me an opportunity to copy it.

  3. When installing the LetsEncrypt SSL the script ask if port 443 has been forwarded. Being in a remote VPS I do not know how I can do that and do not know if it is done. In the script I have answered that I am on a remote VPS and the script then assumes that no prtforwardding is needed.

So I now am not sure if I need to do any portforwarding on the VPS before I can go back and install LetsEncrypt.

The script is very promising and thanks a lot for the work.

It seems I could answer yes to the port 443 forwarding. The script worked OK.

I got another issue.

I have registered a domain (domain.com) and a subdomain (next.domain.com) and they are active DNS.

For the LetsEncrypt SSL I do not know what domain to choose , neither when the script want me to define the subdomain for nextcloud and collabora.

The script propose cloud.domain.com for nextcloud. Can I use next.domain.com instead?
Which domain should I give when the script ask for which domain I want to use the letsEncrypt?

Should I register 3 domains with DNS register - domain.com, cloud.domain.com and office.domain.com?

vm usually are bridge to a nic, witch is nated by your router.

your local windows/linux computer get an ip like
you vm gets another ip like

In your router, use internal nat rules to redirect ports 443 to 443 on vm-ip
do the same for all ports of your vm ( 80:443:21:21…)

I think you misunderstood. I am not on a local server or local vm, but a remote vps-server.

It seems the script worked OK when I answered yes to the question about port 443 forwarding. I think I also saw a message that the port was open.