Unauthorized WOPI host help

Hi all, i get this message when trying to edit a doc:

unauthorized wopi host. please try again later and report to your administrator if the issue persists

Now y main though is i installed this via docker as office.domain.com, but I’ve changed config to collab.domain.com (We use Office365 here, so office;domain.com would potentially confuse users)

Can comeone guide me through?

This is on our Live POC - IT’s 25 users, running for 3 months. My last task remaining (We built POC as a filesharing, and then it became “Can we do this…”

Looks like the docker start command is wrong

Yes, that’s what I’m looking for…

As I’ve already installed, is there a command i can run to restart the docker using my correct path?


docker run -t -d -p -e ‘domain=collab\.domain\.com’ -e --restart always --cap-add MKNOD collabora/code

It was installed with

docker run -t -d -p -e ‘domain=office\.domain\.com’ -e --restart always --cap-add MKNOD collabora/code

but am i right, in that this would then re-install? - would the correct switches being changed just reconfigure the start command?

Everything else is working, just this…

docker ps -a
docker stop XXXXXXXXXXXX

Awesome - So i can see that stops my current, and removes the current.

Is there a further command i need to tell it to use the new location\address?

(Appologies for dumb questions, I’m still picking up Linux\Nextcloud - Hence POC!!)

docker run -t ...

as mentioned in the link above

1 Like

Ok - So what i’ve done:

docker ps -a
docker stop (Container ID)
docker rm (Container ID)
docker ps -a (To confirm - All removed)

docker run -t -d -p -e ‘domain=collab\.domain\.com’ -e --restart always --cap-add MKNOD collabora/code

Restart apache

Still get the error

The only thing is, my POC is hosted on cloud.domain.com/Nextcloud - Would that break it?

My SSL certificate is for cloud.domain.com

You need a valid SSL certificate for the collabora server too.

Yes, i have that, and i have the config file pointing to that to clarify -

SSL for Nextcloud is cloud.domain.com
SSL for Collab is collab.domain.com


Compare to the link i have posted.

docker run -t -d -p -e 'domain= cloud\.domain\.xx|nc\.domain2\.xx ’ -e 'username= admin ’ -e 'password= Secret.Password ’ --restart always --cap-add MKNOD collabora/code

Ok - So i removed the |nc\domain2\.xx** based on the guide here: https://nextcloud.com/collaboraonline/

As i only run 1 nextcloud - the above link states that the extra is not required unless using the docker on more than 1 nextcloud

The username\password is not stipulated in this guide as well - Can you clarify why it is on yours?

Those are the credentials of the Collabora Admin Console.

OK - I pass some credentials in i get the > icon…

I remove them and i can add.

My command i run to create is:

docker run -t -d -p -e 'domain= collab\.domain\.com’ --restart always --cap-add MKNOD collabora/code

If i go to https://collab.domain.com/hosting/discovery - that works suggesting it’s up and running

I have a SSL Certificate for collab.domain.com

So stuck in a loop ATM…

Two things:

One, the command should be:
docker run -t -d -p -e 'domain=office\.domain\.com’ --restart always --cap-add MKNOD collabora/code

Two, I ran into this a couple of times and had to have both certificates under the same certificate. So, the office.domain.com and collab.domain.com are both in the same cert.

Sorry for still not getting this and the following questions, - one thing does not make sense…

Which is the advice to run ‘domain=office.domain.com

My NEXTCLOUD domain is cloud.domain.com
My collab setup is collab.domain.com

So - Should the docker run command be for my Nextcloud, or collab - As i read it as run the domain=office\.domain\.com, i’m running non-valid domain, so it should therefore be domain=cloud\.domain\.com (If it should be the nextcloud host), or domain=collab\.domain.com (If i run the command based on my collab setup


Ok thanks - Good news WOPI error gone…

Now we have:

Proxy Error
Reason: Error reading from remote server

My word, this has been fix 1 error, then the next all the way!


I am not sure if I have come across the exactly same problem with you. Let me share here:-

Problem 1 - Wrong setting at docker run
Solution: domain=collab.domain.com should be the domain name of your NEXTCLOUD, not collabora

Problem 2 - Certificate
Solution: I use self-signed cert, and I need to add the certificate to ca_bundle.

Problem 3 - DNS
Solution. make sure the domain name you entered NextCloud setting for collabora can really be resolved. localhost ? are you doing it within docker network ?

Problem 4 - reverse_proxy
I did not come across problem with nginx reserve_proxy setting. You may wish to double check reverse_proxy settings. My experience (other applications) is that the problems comes from incorrect reserve_proxy settings and also virtualhost settings (like forgot to put the cert for collabora in a proper directory, or the reverse_proxy sections doesn’t point to the correct cert.

Hope that the above help, as I am also new to NextCloud (one week or so).


Pleas start a new thread for that issue.