Unable to upload files

I have had a nextcloud for some time, but recently I have lost the ability to upload files. I can create folders, If I try to create an office document (Collabora) I get an error about reading the template directory, but if I refresh the folder, the office file is there. I cannot create a text file though.

I have checked permissions and ownership, and all seem to be correct. I have chown and chmod the file structure just to be sure.

I have checked config files and logs for anything obvious, but I am at a loss.

running occ files:scan or occ maintenance:repair (among other shots in the dark) does not help.

I have read many forum posts and websites, but I cannot find a solution.

I am running nextcloud as a docker on Unraid. I use Nginx Proxy Manager to access.

Any suggestions would be welcome. I do not want to have to rebuild the entire system.


If the office file is there, then creating files seem to work. The error message about the templates is something else, I think.
If you entered a folder for the collabora templates in your personal settings, then this folder must exist, otherwise NC complains about this folder not existing. Check your settings here and if the field contains a folder, make sure it exists or delete the entry.

What error message do you get, when you try to create a text file? Can you please try to create a text file again and show us the last log entry? Maybe increase the log verbosity if you don’t see any new log entries at all.

I hope you didn’t break anything when you manually interfered with the file permissions on the system level. Are you familiar and feel comfortable on Linux with file permissions and ownership? Otherwise feel free to post a screenshot of the output of ls -l of your file/ folder structure of your data folder. No need to show folder and file names, just like that:

drwxr-x--- 1 www-data www-data
-rw-r----- 1 www-data www-data
-rw-r----- 1 www-data www-data
-rw-r----- 1 www-data www-data
drwxr-x--- 1 www-data www-data
drwxr-x--- 1 www-data www-data
-rw-r----- 1 www-data www-data

And while you are on the server, can you check if you see the files (which you tried to create) on the filesystem level?

Please also check the nginx error logs and maybe post the entries which you find suspicious.

Important: From all the data you paste here, please remove sensitive information like URI/ server address, account names (linux and NC user accounts), IP addresses and of course password (if should be listed anywhere).

thanks for the reply.
the /Templates directory exists, and contains templates

Now when I try to create a text file, the browser locks up and I need to refresh the page.
If I try to upload a file, this is the log file

permissions (note my nginx server user is abc)

PS. I have a feeling it is a docker issue. I may have to migrate to a new docker instance

Did you play around with the app fileaccesscontrol? “Access denied to application/x-photoshop” reminds me of mimetypes and access control for specified mimetypes. Maybe in combination with added tags to that folder?

Except the fact that files and folders are world-readable, the permissions of FS level look good.

these are all photoshop, because that is what I had on my desktop for easy drop. I get the same error on all file types .rtf, .txt, .jpg, etc

Yes, okay, but

  • have you configured something with file access control?
  • does the folder have a tag applied?
  • is this a shared folder from another user or are you accessing this folder via a public link or so?

If that all is not the case, then yes, maybe a docker issue with missing permissions to write data to your nc data directory.

At first I thought it was shared folders, but it is all folders, I even created temp folders. I have also created different users, and same issue.
I think next week I will create a new docker instance and move all the data.
It may also have something to do with using an underpowered server (old PC) that I was trying to repurpose.