Unable to upload certain file types... Ideas?

Hi guys,

php.ini has max_post and file size at 2G and execution at 600secs so don’t think this is a file size issue straight away please :wink:

I can’t seem to upload certain file types on a brand new install of 12.0.3 - one of the offending file types is any video format; have tried avi, mpeg, mp4 - yet renaming the file to .test it uploads fine (I can also rename it to its original file type afterwards and it save and downloads without issue)

Have tried replacing the /apps/theming folder as that was suggested as a possible solution but didn’t seem to help.

Any ideas why certain file types seem to be blocked or not working?
I doubt its my provider as OwnCloud works fine with the same files, I am in fact trying to move data from a working OwnCloud install to a NextCloud install as I feel I’m ready to graduate to a real solution :wink:

Log file gives me:
{“reqId”:“WeT3Hh5zuOxjosY6Ni4dZwAAAiw”,“level”:3,“time”:“2017-10-16T18:15:02+00:00”,“remoteAddr”:“A.B.C.D”,“user”:“myaccount”,“app”:“no app in context”,“method”:“GET”,“url”:"/remote.php/webdav/TESTFILE.mp4",“message”:“Exception: {“Exception”:“Symfony\\Component\\Routing\\Exception\\RouteNotFoundException”,“Message”:“Unable to generate a URL for the named route \“theming.Theming.getLogo\” as such route does not exist.”,“Code”:0,“Trace”:”#0 \/home\/mydomain\/public_html\/Cloud\/lib\/private\/Route\/Router.php(339): Symfony\\Component\\Routing\\Generator\\UrlGenerator->generate(‘theming.Theming…’, Array, 1)\n#1 \/home\/mydomain\/public_html\/Cloud\/lib\/private\/URLGenerator.php(77): OC\\Route\\Router->generate(‘theming.Theming…’, Array)\n#2 \/home\/mydomain\/public_html\/Cloud\/apps\/theming\/lib\/ThemingDefaults.php(165): OC\\URLGenerator->linkToRoute(‘theming.Theming…’)\n#3 \/home\/mydomain\/public_html\/Cloud\/lib\/public\/Defaults.php(186): OCA\\Theming\\ThemingDefaults->getLogo(true)\n#4 \/home\/mydomain\/public_html\/Cloud\/core\/templates\/layout.guest.php(45): OCP\\Defaults->getLogo()\n#5 \/home\/mydomain\/public_html\/Cloud\/lib\/private\/Template\/Base.php(176): include(’\/home\/mydomain\/…’)\n#6 \/home\/mydomain\/public_html\/Cloud\/lib\/private\/Template\/Base.php(151): OC\\Template\\Base->load(’\/home\/mydomain\/…’, NULL)\n#7 \/home\/mydomain\/public_html\/Cloud\/lib\/private\/legacy\/template.php(202): OC\\Template\\Base->fetchPage(NULL)\n#8 \/home\/mydomain\/public_html\/Cloud\/lib\/private\/legacy\/template.php(224): OC_Template->fetchPage()\n#9 \/home\/mydomain\/public_html\/Cloud\/lib\/private\/Template\/Base.php(132): OC_Template->fetchPage()\n#10 \/home\/mydomain\/public_html\/Cloud\/core\/templates\/403.php(7): OC\\Template\\Base->printPage()\n#11 {main}",“File”:"\/home\/mydomain\/public_html\/Cloud\/3rdparty\/symfony\/routing\/Generator\/UrlGenerator.php",“Line”:130}",“userAgent”:“Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36”,“version”:“”}Preformatted text

You are using your own theme?


$CONFIG = array (
  'instanceid' => 'oc5353afsy2e1a',
  'passwordsalt' => 'xxxx',
  'secret' => 'xxxx',
  'trusted_domains' => 
  array (
    0 => 'nextcloud.jonesyjon.co.uk',
  'datadirectory' => '/home/user3342/Data',
  'overwrite.cli.url' => 'http://nextcloud.jonesyjon.co.uk',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'mainadmin',
  'dbpassword' => 'xxxx',
  'installed' => true,

Only theming I’ve done is in the theming options from the admin menu so far

(although would like to customize it at some point with some css etc)

Can you use the default theme and undo the customization?
If you rename a txt-file to a *.avi, does it fail as well? Can you upload via NC client or directly via webdav? Can you also check your other logfiles (especially webserver)?

What system are you using?

Hi tflidd,

I’ve deleted the entire directory of both data and installation directory and used the zip file download rather than the setup_nextcloud.php file and set up using an empty database rather than sqlite. It seems to be working as intended now.

Not sure if it’s the database, the php installer, permissions or something that messed up when I tried changing the background using settings and theming.

Thanks for the help, at least I have a working base I can start experimenting with and maybe find a workaround if the problem pops up again.