Unable to upgrade from 25.0.0 RC 1

From the console, an upgrade is reported as available.

$ /opt/plesk/php/7.4/bin/php occ update:check
The current PHP memory limit is below the recommended value of 512MB.
Nextcloud 25.0.0 is available. Get more information on how to update at https://docs.nextcloud.com/server/25/admin_manual/maintenance/upgrade.html.
1 update available

However, the system will not process the upgrade.

$ /opt/plesk/php/7.4/bin/php occ upgrade
The current PHP memory limit is below the recommended value of 512MB.
Nextcloud is already latest version

From the web interface, the situation is stranger.

A password is requested during the upgrade process, but it is usually rejected. When it is, cofig.php is rewritten with the hash of a different password. I have tried this process many times.

Occasionally, the password is accepted, after I repopulate the file with my own hash, for which I know the password. However in the upgrade screen, all the check marks are already filled, and pressing the button to start the upgrade simply returns the application immediately to the home screen.

I believe the upgrade process may earlier have been initiated but not completed.

Some sources suggest looking in the updater directory for files with names beginning in .step. However I find no such files.

$ ls -1A updater/
index.php
updater.phar

The installed version is 25.0.0 RC 1. An upgrade should now be possible to the release, 25.0.0.

How may I restore the installation to a viable state?

This issue was addressed within the release candidate cycle.

PHP issue

But, your issue is a different one. Have you considered searching the forum and internet for that php error?

Search results for 'The current PHP memory limit is below the recommended value of 512MB' - Nextcloud community.

Here is a random Nextcloud setup guide from the internet

Warning 2: Small PHP memory limit

The PHP memory limit is below the recommended value of 512MB.

To fix this we need to edit the ‘php.ini’ file to increase the maximum amount of memory that the PHP process can consume. While we’re there, we might as well increase the maximum upload limit too.

sudo nano /etc/php/7.2/fpm/php.ini

Now look for the following values within the php.ini file and change them as needed. You can increase the PHP memory limit above 512MB if you wish.

On my production server, I have the PHP memory limit set to 1GB, as my server has 4GB RAM.

# Default is 128M
memory_limit = 512M 

# Default is 2M
upload_max_filesize = 100M

# Restart PHP service again
sudo systemctl reload php7.2-fpm.service

Restart PHP again to apply the new settings and head back to the admin overview screen. Hit refresh and hey presto! Two of the warnings are already gone. Life is getting better all the time!

Thank you for the response.

In my case, no directories exist following the given naming pattern.

$ ls -1
3rdparty
apps
AUTHORS
config
console.php
COPYING
core
cron.php
dist
index.html
index.php
lib
occ
ocm-provider
ocs
ocs-provider
public.php
remote.php
resources
robots.txt
status.php
themes
updater
version.php

Did you follow the php instructions above? The error you listed has nothing to do with .step

Yes, the directions give the pattern as names beginning in updater-. As you see in the listing, no such names exists.

Again, follow the php instructions earlier in the thread

I am sorry that I missed the main point of your message based on my original inspection.

I believe the message about memory is only a warning based on a prescribed rule.

Please note the following.

$ /opt/plesk/php/7.4/bin/php -d memory_limit=1024M occ upgrade
Nextcloud is already latest version

The message about memory resolves, but the main issue does not.

Does this test address your response, or have I still missed the point?

Note, also, that while I cannot edit the host system configuration directly, my hosting service is configured for the higher memory usage for invocation through the web server (see below image).