Unable to Update NextCloudPi (Docker) due to PHP version mismatch

Hello there,
I am still stuck with my NextCloudPI v1.49.1 on docker because after any attempt to update to the current docker version (atm. v1.50.2) I get only the message:

This version of Nextcloud is not compatible with > PHP 8.0.
You are currently running 8.1.10.

when accessing my nextcloud. NCP login over Port 4443 still works.

What’s the problem?

Greetings,
Zusch